Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Conntecting the posts with translations

Solution: The client has created posts in each language. So the posts in secondary languages will be individual one as not the translation. It works as expected after the following steps.

1) Open your secondary language Page/Post for edit, then click on *Connect with translations* link of *Language* widget on the right side

2) Search for the newly created Page/Post in the primary language

3) Choose that Page/Post and click on the *Ok* button

4) Uncheck the *Make "Secondary language" the original language for this page* and click on *Assign* button

5) After the *Assign* action, confirm the secondary language Post/Page will become the translation of the selected default language Page/Post or not

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by michaelD-67 2 years, 12 months ago.

Assigned support staff: Bigul.

Author Posts
November 25, 2018 at 12:11 pm #2937534

michaelD-67

Dear WPML Supporter,
My client already has a big number of articles translated in 2 languages : Greek and English (100 + 100). Can you tell me how to match these articles to avoid the translation proccess again. I want to match Greek article to an already exist English article.

Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece

November 28, 2018 at 8:37 am #2947018

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Michael,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following steps after a full site backup to link your English and Greek articles. Then let me know your feedback.

1) Open your secondary language Page/Post for edit, then click on *Connect with translations* link of *Language* widget on the right side
2) Search for the newly created Page/Post in the primary language
3) Choose that Page/Post and click on the *Ok* button
4) Uncheck the *Make "Secondary language" the original language for this page* and click on *Assign* button
5) After the *Assign* action, confirm the secondary language Post/Page will become the translation of the selected default language Page/Post or not

Please check the attached images for more details.

--
Thanks!

Bigul

2018-11-28_1404_001.png
2018-11-28_1404.png
2018-11-28_1403_001.png
2018-11-28_1403.png
2018-11-28_1402.png
November 28, 2018 at 10:25 am #2947420

michaelD-67

Dear Sir,
Thank you for your great support as always.
In my Articles in Edit Mode I don't have the option *Connect with translations* in any article that I check and I don't see the option as you saw me in image 2018-11-28_1402.
I attach an image that you can see.

Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece

ELPS_WPML.png
November 28, 2018 at 2:26 pm #2948537

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Michael,

Thank you for the updates. We have released the new version of WPML(4.1.0). Please upgrade to the latest version of the plugin after a full site backup and check the issue is existing.

Which is your primary language English or Greek? Please check in an English post and make sure you have this option or not?

If you are still having the issues, Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

November 29, 2018 at 9:40 am #2951307

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Michael,

Thank you for the updates and login information. Please check the attached images. Expect the first post of Greek and English, all the posts were showing the *Connect with translations* option and most of the posts are translated in to English also.

Please check it once again and let me know your feedback. Is it only happening with the specific posts, am I right?

Please create a test post in Greek and English(not translation) and check the issue is existing or not.

--
Thanks!

Bigul

2018-11-29_1508.png
2018-11-29_1506.png
2018-11-29_1459.png
2018-11-29_1456.png
2018-11-29_1455.png
November 29, 2018 at 12:39 pm #2952004

michaelD-67

Dear Sir,
Thank you very much for your great support. Yes all the articles are OK in 2 languages except 12 first articles in all languages (6+6) that I can't have tis option. How can I fix these articles with translations?

Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece

November 29, 2018 at 3:47 pm #2953097

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Michael,

Thank you for the updates. There are 58 posts in English, and 57 of them are the translation of the Greek posts. So you have to translate the remaining Greek posts to English, am I right?

Please check the attached image for more details and let me know your feedback.

--
Thanks!

Bigul

2018-11-29_2117.png
November 29, 2018 at 5:49 pm #2953564

michaelD-67

Yes, you are right but I see only 6 English and 6 Greek articles that have problem ( I don't see the option for matching). These articles has already translations. Every article that begins with ΕΛΠΣ is in Greek Language and every article begins with HPSC is in English language from my client. All the other articles are OK.

Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece

November 30, 2018 at 12:14 pm #2955958

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Michael,

Thank you for the updates. The issue is happening because six of those *HPSC* posts were created in Greek instead of English. Please change the language of the those *HPSC* posts to English(after a site backup) and make sure you can connect them to Greek posts.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

2018-11-30_1743.png
2018-11-30_1742.png
2018-11-30_1741.png
November 30, 2018 at 5:20 pm #2957027

michaelD-67

My issue is resolved now. Thank you!