Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Yvette 5 months ago.

Assigned support staff: Yvette.

Author Posts
February 21, 2020 at 2:48 pm #5541691

R.J.

I am trying to:
Create a footer in 2 languages. Creating the footer element with beaver themer / Themer layouts.

Link to a page where the issue can be seen:
hidden link

I expected to see:
an english version of the image at the footer

Instead, I got:
The dutch version

February 24, 2020 at 4:01 pm #5556145

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Clarification
When you view the Footer theme elements in each language independently from their being integrated into the theme, do they appear correctly in each language?

e.g. in the editor view of the footer, do they appear in the right langauge?

2. Theme Builder compatibility
I will need to research if the Beaver Builder theme builder is translatable/compatible with WPML.

February 26, 2020 at 9:59 am #5569359

R.J.

Hi thanks for your reply, but i thought my epxlenation shows what my issue is.

herby a video that shows exactly what happens.
hidden link

----
Its a little bit complicated to understand an explain the technical details with the right terminology i guess. So i hope i understand you correctly, and i hope you understand me correctly.

- The screenshots show the footer theme element i created.
- The dutch version shows dutch, the english, english

- I do not understand 'independently from their being integrated into the theme'
As above, an visible in the screenshots, independently viewed in the theme builder, switching between the languages they appear correct.

2. Beaver builder and Themer compatibility: Yes its compatible. Other theme parts also work (correctly).

Please do not understand me wrong, but if you are not familiar with the beaver themer compatibility, its better to transfer the case to someone who does.
The beaver themer is a step further than the builder.

February 26, 2020 at 11:15 am #5570077

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

My research has turned up that WPML will support the themes listed on this page:
hidden link

So this should be compatible. Your video, however, does complete all the expected steps for translating the theme sections.

1. If you change your active theme to the parent theme, does the section still not translate?

2. Could you send us a copy of your site using the Duplicator plugin as per this article:
https://wpml.org/faq/provide-supporters-copy-site

I am opening the private are for this.

February 27, 2020 at 1:02 pm #5578159

R.J.

1. If you change your active theme to the parent theme, does the section still not translate?

RW: i tried and it dit not resolve the issue

February 28, 2020 at 10:38 am #5584431

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I was able to get this to work on my local copy by changing the location rule to be "Pages = All Pages"
For some reason, when the rule is kept at "Entire site", the template is not applied.

Can you try this as well?
Here is screencast of what I mean: hidden link

I also changed some multlingual settings for custom fields but I am not sure this is really what made it work in the end.

Thanks for letting me know the results on your site.

February 28, 2020 at 3:45 pm #5586847

R.J.

Hi Yvette, thaks for getting back. I see the result of your video, but unfortunately i cant get it working. Sor probably theres something else you changed.

See my new video for the result.
hidden link

March 1, 2020 at 7:01 pm #5595235

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmm - ok.

Could you please edit your original language Footer3. Scroll down to the Multilingual OPtion sections and expand it to also include Hidden System Fields. (see image)

Then make sure your settings are the same as what is in the image.

Resave your post and also save the translation.

Does it work now?

March 2, 2020 at 3:36 pm #5600531

R.J.

Hi Yvette,

i do not see the options that you show here.
I checked the settings, but everything is activated.

Maybe you have some kind of extra tools to show this.

March 3, 2020 at 1:46 pm #5608445

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

March 4, 2020 at 4:52 pm #5619095

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

You did not have the Translation Management or String Tranlsation modules activated and these are necessary to make sure you are translating the custom fields

I activated the plugins and set the various system fields to be as they are in my test system.

There is progress.

Now, you can set the "page" for which the footer should appear. The option of "all pages" that I used on my local host with your site copy is not working on your site. This may be because on my local server, only WPML and your theme are activated. There may be some other conflicts at hand.

So, I would ask that you deactivate all of your non-WPML plugins, only keeping the Beaver plugins activated. Then, see if the option to use "all pages" works.

Otherwise, your only immediate workaround is to set a location rule for each of your site pages as on the page level, the rules seem to apply correctly.

I wait for your feedback.

The topic ‘[Closed] Translation of beaver themer 'Footer' element is not working’ is closed to new replies.