This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by bettinaS-7 3 weeks, 5 days ago.

Assigned support staff: Bruno.

Author Posts
August 9, 2019 at 12:33 pm

bettinaS-7

I am trying to: translate the whole website / each page

Link to a page where the issue can be seen:

I expected to see: all the content of each page

Instead, I got: Only two fields which can be translated, not the complete page.
I am trying now for hours and I would be very grateful, if you help me.
I would like to finish the translation this weekend...

August 9, 2019 at 11:11 pm #4373155

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. At the moment Muffin Builder only works by being translated with the Advanced Translation Editor or by using the manual translation, duplicating the page to the secondary language and then translating it independently: https://wpml.org/2019/05/bethemes-muffin-builder-is-now-compatible-with-wpml/

That is, if you do not want to use ATE, you will need to use manual translation of Muffin Builder. To duplicate the page, you can see the step-by-step in our documentation: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

August 12, 2019 at 7:42 am #4378905

bettinaS-7

Hi Bruno, also the manual translation is not possible. I still only see the two fields as shown in the jpg which I sent you with my first request. I checked the memory and it is only 40 M, but it should be 128 MB (I enclose a screenshot). Do you think that could be the reason that the pages cannot be translated?
Regards,
Bettina

August 13, 2019 at 1:41 am #4384117

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Bettina,

In the case of memory, yes, you should increase this because 40Mb may not be enough. You can see the step-by-step here: https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php.

However, this should not have relevance with the fields not being displayed. In the case of manual translation, it would be necessary to duplicate the page and then translate it independently. The steps below would be as follows:

- Click on the Pages > All Pages
- Click to edit the "Home"
- On the top bar, switch to the secondary language
- Click on the "Overwrite with .... content." button
- When the page reloads, you must click on the "Translate independently" option
- So you could translate this content

I didn't follow the steps above on your site because WPML is not installed on your site, but the steps are basically the steps above. That is, the translation will be done in the native interface of WordPress and "Muffin Builder" to the secondary languages as well.

Thank you.

August 14, 2019 at 2:49 pm #4396197

bettinaS-7

Hi Bruno,
I activated WPML again. Same problems. I deactivated it again and removed it completely and activated WPML again... I followed each individual instruction, but the result is the same. I still only see the two fields. If you check this page, I would be very grateful. WPML is active, so that you will see the problems immediately. Thank you so much for your support. I hope that we can solve this problem... my customer is not very satisfied that it takes so long to show the English translation.
Kind regards,
Bettina

August 14, 2019 at 11:16 pm #4397943

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Bettina,

Thank you. Now that WPML is installed I was able to test your site a bit more. Basically, the steps you should follow are the ones I posted above and then simply refreshing the page. Since you are using the Gutenberg editor, content is not being updated automatically. These are the steps I follow:

- Open the Home page in German
- Switch to the secondary language using the top bar selector
- Insert some title to the English page
- Click to publish the page
- After the page is saved, refresh the page

After following these steps, Muffin Builder content was displayed in the secondary language editor as well. Now just translate the content.

Remember again that in Muffin Builder you cannot translate using the Translation Editor. That is, you must use the language selector in the top bar to translate content just as you create it in the default language.

Please, could you verify that by following the steps above the content is displayed correctly?

Thank you.

August 20, 2019 at 2:59 pm #4424747

bettinaS-7

My issue is resolved now. Thank you!