This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Dennis 4 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
June 13, 2019 at 7:30 pm #4016667

johannV-2

Hi there,
I m using WCMP marketplace plugin on my website. This plugin creates additional Woocommerce emails. As for Woocommerce default emails you can change the subject and headline of those emails as shown in the attached screenshot. However I cant find those strings in the WPML string translation. I also checked all my themes and plugins for new strings but they wont show up. The default subjects and headlines of the plugins emails are shown properly in the string translation but not the customized ones. When changing the subject or headline of the default Woocommerce emails they will appear in the string translation but not so the WCMP email. I also contacted the WCMP plugin support but they cant solve this problem.
Your help would be highly appreciated.

June 14, 2019 at 2:21 am #4017617

Dennis

Hi,

Welcome to WPML Support forum.

Could you please share your Debug information with me? You can read the detailed explanation about it here.

http://wpml.org/faq/provide-debug-information-faster-support

The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

To translate the plugin strings, Please try the following steps:

-go to WPML > Theme and plugins localization. Be sure that 'Translate themes and plugins using WPML's String Translation only (don't load .mo files)' is selected.
-under Strings in the plugin section, select WCMP marketplace plugin.
-click 'Scan selected plugins for strings'
-go to WPML > String Translation
-find and translate the string. check 'translation is complete' . click 'save'

If you still can't find the string, It could be that these strings are stored in the admin texts.

Please go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

Please check our documentation about this:
https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

Does it help? Please let me know how it goes.

Kind regards,
Dennis

June 14, 2019 at 5:00 am #4018583

johannV-2

Thanks for your reply Dennis, I found the strings in the "translate texts in admin screens" section. I selected them and pressed apply but they still not showing in the WPML string translation. How it comes?

June 14, 2019 at 8:27 am #4019293

Dennis

Hi,

Thank you for your update.

Could you please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.
Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then try to search for the strings again in WPML > String Translation > Translate texts in admin screens », select the strings and click 'Apply' and translate them completely in WPML > String Translation table.

Does it help? Please let me know.

Kind regards,
Dennis

The topic ‘[Closed] Translation of customized Woocommerce emails’ is closed to new replies.