This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Itamar 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 11, 2019 at 6:11 pm #3791151

paulL-22

I am trying to:translate an event feature

Link to a page where the issue can be seen:

I expected to see: the chosen month in the language I choose

Instead, I got: the original language with the current month

May 12, 2019 at 8:52 pm #3793915

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I think that you are using the Saves theme by ChurchThemes.
hidden link
Is it correct?
If so, then please be aware that this theme is not officially compatible with WPML.

Fortunately a few months ago I've handled the same issue and our compatibility team has found a workaround for this issue. You can see this ticket here.
https://wpml.org/forums/topic/the-event-feature-translation-cant-move-forward/
The workaround is to add the following code to the functions.php file of the theme.

add_action( 'ctc_update_recurring_event_dates_after', 'ctc_sync_to_translations' );
 
function ctc_sync_to_translations( $id ) {
        do_action( 'wpml_sync_all_custom_fields', $id );
}

https://wpml.org/forums/topic/the-event-feature-translation-cant-move-forward/page/2/#post-3046391
Could you please try this workaround and see if it is also working for you?

Thanks,
Itamar.

May 12, 2019 at 10:20 pm #3793969

paulL-22

Hi Itamar,
I have this function in my function.php file in the child theme.You gave it to me to resolve the problem with recurring event but the issue I have now is only for the month in french in this particular location of this feature. Look the picture in "EVENT-FRENCH", when I tried to click on "Octobre 2019", it reverts back to the English language with the current month "May 2019". Also the two functions you gave me in this ticket are the same.
I am waiting for your reply.

May 14, 2019 at 12:10 pm #3806609

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

OK, I see now. Sorry that I didn't realize that it was you on the other ticket. I've tried to see the problem on your site, but it is in a 'coming soon' mode.
Could you please let me have access to your site and explain to me the exact steps of how to see the issue?

If you need further help with this, please share the access details to your site with me.
I'm enabling private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

May 15, 2019 at 12:40 pm #3816495

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I can see the issue on your site. I think that the problem is happening because the month argument (?month=2019-06) comes after the language argument (?lang=fr). For example, in this link. hidden link
Please also see the attached screenshot.
I think that this issue will not happen if you would change the Language URL format to 'Different languages in directories'. In this case, the URL structure of your site for the French language would be this. hidden link. And as I wrote I think that the problem wouldn't happen. Can you please try that and see if it helps? Here is what you need to do.
1. Take a backup of your site.
2. Go to WPML -> Languages -> Language URL format.
3. Change the Language URL format to 'Different languages in directories'.
4. Save the settings.
5. Go to Settings -> Permalinks and re-save the permalinks of your site.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Regards,
Itamar.

May 15, 2019 at 1:45 pm #3817185

paulL-22

My issue is resolved now. Thank you!

May 15, 2019 at 1:52 pm #3817265

paulL-22

In the same place, When I put the month on "July 2019" for example and I change the language to french, I expected to see the month "Juillet 2019 but the page reverts to the current month "Mai 2019" in french. It's the same thing if I put it first in french on "Juillet 2019" and change to English, I expected to see "July 2019" but it reverts back to "May 2019"
Can you please take look to see.

May 15, 2019 at 1:55 pm #3817391

paulL-22

I am waiting for your reply.

Thanks.

May 16, 2019 at 1:43 pm #3826469

paulL-22

Hi Itamar,
I am still waiting for your help.
Thanks.

May 16, 2019 at 6:59 pm #3829073

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and sorry for the late reply here.

Since you have marked this issue as resolved (probably by mistake) the access details that you gave me are deleted, and I can't see them. This is being done by our system as a security measurement to protect your site. Therefore I cannot access your site now.

Nevertheless, it would be better to debug this issue on a fresh WordPress installation. Then when the issue is replicable on the fresh installation I can escalate it to our compatibility team. For this, I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install the Saved theme and see if the issue is replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site.
Please also make sure that you are installing the latest version of the theme.

Thanks,
Itamar.

May 16, 2019 at 7:38 pm #3829255

paulL-22

send me a secure line so I can send you login information.
Thanks.

May 16, 2019 at 9:05 pm #3829407

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

A private message is activated for the next reply.
Please also follow the instructions from my previous reply and replicate the issue on the test site.

Thanks,
Itamar.

May 19, 2019 at 6:55 pm #3842339

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

This is now solved on your site. Here is what I did.
In WPML -> Languages -> Language Switcher options, I inserted the 'month' argument in the 'Preserve URL arguments' fields. Please see the attached screenshot. Now when switching language when a certain month has been selected, the translation of the month shows. You can read more about it in our documentation here.
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#preserving-url-parameters

Can you please confirm that it is working now?

Thanks,
Itamar.