Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.14 hours from now. Thank you for your understanding.

This topic contains 25 replies, has 2 voices.

Last updated by Radu 1 year, 8 months ago.

Assigned support staff: Radu.

Author Posts
October 4, 2019 at 5:29 pm #4697809

richardW-15

I am trying to:translate files of a custom post type

Link to a page where the issue can be seen: hidden link

I expected to see: upload-fields in the backend

Instead, I got: no upload-fields

I got the fields in the translation editor, but there are no select fields for the files. Can't use it for my customer.

Thanks for your reply.
Richard

Screenshot_2019-10-04 Edit Installation Drawing ‹ BG-Graspointner — WordPress(1).png
Screenshot_2019-10-04 Edit Installation Drawing ‹ BG-Graspointner — WordPress.png
October 7, 2019 at 5:43 am #4704253

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Richard,

Thank you for reaching out the WPML support!

Is there any chance that you could give me access to the dashboard area, please? This way I'll be able to have a look at the way that the custom post type and fields are created and have a closer look at why is this not translating as expected.

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

October 8, 2019 at 10:36 am #4714317

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Richard,

I just had a look at the custom field and I could see that you created them right here hidden link. Now, if you use the language switcher from the top admin bar, you can see that these fields are not created in French.

Can you create these custom fields for the French language too and then try to edit the French version of the FCT one LN200 Fiche Technique, Accessoires sheet, please? This time, the custom fields will be available. Just give this a try and tell me how it goes.

Thanks,
Radu

October 8, 2019 at 1:59 pm #4716145

richardW-15

Hello Radu,

please let me know, how to translate (not just create?) these Custom Field Groups.

I set the Custom Fields to "translateable" (WPML--> Settings) and i set the Translation Preferences (WPML--> Edit Post Field Group) to "Translate".

What else am I missing?

October 10, 2019 at 7:55 am #4728199

richardW-15

Hello Radu,

any news on my issue? Please let me know cause my customer is waiting for a solution.

Kind Regards,
Richard

October 10, 2019 at 9:50 am #4728945

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Richard,

I did look at this one more time yesterday and I managed to find a way to translate it. Can you check again the FCT one NW200 Spec sheet, Accessories sheet and tell me if it's translated, please?

I just added [FR] at the beginning of the translated title to see that's different than the original sheet. Please have a look.

Thanks,
Radu

October 10, 2019 at 10:07 am #4729091

richardW-15

Hello Radu, thank you for your answer.

That's not an issue. The translation in the Translation-Editor was already working. My problem is, that custom fields are not showing up on the french edit page. Please see my uploaded images on my initial post.

Richard

October 13, 2019 at 6:22 am #4744079

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Richard,

In order to have the fields appear on the French edit page, you need to create the fields in this language too.

Right now, the fields from here hidden link are the ones that are displayed in English. However, if you go to the French dashboard area here hidden link, you can see that there's no fields group.

Basically, there are two ways to translate the fields:
1. Like I already did, by creating the custom fields in one language, use then on a post type (in your case, the Spec Sheets), and then translate them using the translation editor. This way, the value from the English fields will be available for translation, even if the custom fields are not created in French too.
2. You can create a fields group in secondary language too (French in this case), and have the fields appear in when trying to edit the spec sheets (like you asked).

You can try to create the fields group in French, edit an English spec sheet, turn off the Use WPML's Translation Editor option, and add the translation now. This time, the fields will appear here too.

Thanks,
Radu

October 15, 2019 at 10:29 am #4756177

richardW-15

Hello Radu, thanks for your reply.

Do I have to create all the custom fields and assign the group to the the post types? What about the output? Do i have to change the views? Are the languages of the custom fields connected?
Doesn't look as if they are translations. That are just different custom field assigned to french or english.

What is the proper way to have the content of custom file-fields translated - and i don't want to use the translation-editor. I want to have the same fields as in the original language and just be able to translate them - using select-field.

Is this a missing feature or am I wrong?

October 17, 2019 at 7:19 am #4770605

richardW-15

Hello Radu, any news on this?

October 17, 2019 at 11:34 am #4772993

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Richard,

I didn't forget about this ticket. Actually, I was checking it out right now. I also asked some colleagues to look into this too.

The custom fields that you created should automatically appear on the secondary language so now I'm running a few more tests to see if there's any issue between WPML and Toolset, or if I need to get a copy of your website and see why this is happening on your side.

I'm gonna get back to you as soon as I have a bit more info. For now, I just wanted to give you an update and tell you that I'm working on this.

Thanks,
Radu

October 17, 2019 at 1:43 pm #4774267

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Richard,

I copied the custom post type from your website on a clean website here hidden link and I created just one custom field. Now, if you go to the spec sheet I created and try to translate it to French. This time, you should see the custom field.

Can you tell me if this is what you are looking for in your website too please? I want to make sure that I understand what's the change that you're looking for.

Also, I could see that if I try to add a French spec sheet on your website, the Download Links section appears (even though it's empty). Do you remember doing any change in order to see it?

Thanks,
Radu

October 17, 2019 at 2:03 pm #4774605

richardW-15

Hello Radu,

you created a text field. That's already working.
Please try to create a file-field and have a look if the file-field also appears in the translation.

There are fields that can be translated in the Translation-Editor, but not in the WP-editor. And my customer needs the file-field to choose from files in the media labrary.

Thanks,
Richard

October 22, 2019 at 10:27 am #4801199

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Richard,

Can you access the website I send to you on my previous message, please? I created a file and a select field too, edited again the sheet, and pressed the plus sign to add the translation. As you can see, all the fields from the original language are available on the translation too. Can you have a look and tell me if this is what you're looking for, please?

Thanks,
Radu

October 22, 2019 at 2:02 pm #4803107

richardW-15

Hello Radu,

thank you. Yes, that looks good to me. The only thing i would like to add is, to copy the content initially from English to French. Otherwise i could loose the connection to e.g. the product-size.

What do i have to do, to have that soution on my site?

The topic ‘[Closed] translation of file-field not visible (toolset)’ is closed to new replies.