If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I want to translate the content of the field "Header contact block".

Solution: I see your “Header Contact Block” is coming from Appearance >> Customizer section and you can translate customizer strings from WPML >> String Translation as you can see in the attached screenshot. - https://cdn.wpml.org/wp-content/uploads/2019/06/4091759-header_contact_block_customizer.jpg?x34514 - https://cdn.wpml.org/wp-content/uploads/2019/06/4091759-header_contact_block.jpg?x34514

Relevant Documentation: Here is doc for more details: https://wpml.org/documentation/getting-started-guide/translating-theme-options/

This topic contains 7 replies, has 2 voices.

Last updated by Noman 4 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
June 25, 2019 at 4:30 pm #4086201

marieL-7

Tell us what you are trying to do? I want to translate the content of the field "Header contact block"

Is there any documentation that you are following? Yes, I tried this instruction :
To Translate Block 1) Go to Translation management->Multilingual content setup -> Custom posts and set the blocks to be translated. 2) Now go to blocks and translate it accordingly in secondary languages.

But In "Translation management", I don't have "Multilingual content setup"

Is there a similar example that we can see? I don't know

What is the link to your site? hidden link

June 25, 2019 at 4:55 pm #4086313

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. You can find Multilingual content setup page from WPML >> Settings Menu as you can see in the attached screenshot.

Please let me know if this solves the issue or if you need further assistance with this issue.

Thank you

June 25, 2019 at 5:08 pm #4086389

marieL-7

Thanks ! I wasn't in the right page because "Translation management" in french looks more "Gestion de traduction" and "settings" are "paramètres". So I tried to follow the instruction, but there is no string for header contact block... So I still can't translate the content of this field.

Thanks for your help.
Marie

June 26, 2019 at 6:53 am #4089309

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 26, 2019 at 11:01 am #4091759

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I see your “Header Contact Block” is coming from Appearance >> customizer section and you can translate customizer strings from WPML >> String Translation as you can see in the attached screenshot.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Thank you

June 26, 2019 at 11:18 am #4091899

marieL-7

Thank you Noman, your help was efficient and I learnt a new possibility with WPML.

June 26, 2019 at 11:23 am #4092015

marieL-7

Excuse me, Noman, but my back-office is in english now, in Settings, it says "When WPML is activated, the site language should be changed in the WPML Site Languages section.", but when i check out this page, WPML says my website is in french (by default), but it's not... Can you get my back office in french again please ?

Thanks

June 26, 2019 at 12:56 pm #4092619

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have changed your site backend language from Users >> Your profile >> Language dropdown as you can see in the attached screenshot.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/language-setup/setting-the-wordpress-administration-language/

Thank you