This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Edwin 2 months, 4 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 11, 2019 at 2:32 pm #4190953

Edwin

I am trying to: edit translations of pages created with BeaverBuilder.
When trying to edit a translation of a page clicking the plus button takes me to the Translation Basket page not to the Translation manager. This happens to most pages. For some pages it works correct.
This is the case when logged in as a Editor. When logged in as admin it does work correct.
The user with editor rights is enabled as tranlator.

WP 5.0.4
WPML 4.2.6
Beaver Builder: 2.2.3

July 11, 2019 at 7:08 pm #4192793

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Translation Management>>Translation Jobs and make sure the Translation Jobs are existing for the Pages having this issue.

Also please upgrade to the latest version of WPML(4.2.7.1) after a full site backup and check is there any difference in the result.

--
Thanks!

Bigul

July 12, 2019 at 9:09 am #4196851

Edwin

Hi Bigul,
Thank you for your reply.

I have updated WPML, String Translation and Translation Management and also Beaver Builder to the latest versions. There is no diffrence, it still does not work as expected.

I think I need to clarify better. The client is translating/editing both the activated languages themselves. We don't work with an external translator.
Editing the default language Dutch with BeaverBuilder works fine, but when they want to edit the second language German clicking the pencil icon leads to the translation jobs. That should not happen in my opinion.
To be clear; this only happens when being logged in as the user with editor rights. When logged in as an administrator it works as expected; clicking the pencil button leads to the translation manager.
The user with editor rights is enabled as translator.

For 3 pages an translation job exists. Those work (so as the editor clicking the pencil button leads to the translation manager)
Clicking the pencil button on the other pages lead to the screen with the translation jobs and editing that page seems impossible.

Regards
Edwin

July 12, 2019 at 4:22 pm #4200451

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Edwin,

Thank you for the details. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please share me the URL of the pages having the issue for the easy tracking.

--
Thanks!

Bigul

July 15, 2019 at 6:32 am #4207401

Edwin

Hi Bigul,

I will prepare access for you and the requested info today.

Thank you
Edwin

July 15, 2019 at 8:02 am #4208129

Edwin

Hi Bigul

I can't seem to choose to reply privately anymore. That choice is not present.
Please advise how to send the access info.

Regards
Edwin

July 15, 2019 at 12:02 pm #4210815

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Edwin,

Thank you for the updates. I am enabling the private option for the next reply. Please check.

--
Thanks!

Bigul

July 15, 2019 at 5:15 pm #4213685

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Edwin,

Thank you for the updates and login information. This may be happening because all these pages are translated by the admin user and the translation job is existing for it. I have created a test Post & Page and successfully translated as Editor user. Please check the attached images for more details.

So please try with a new Post or Page and check the issue is existing or not.

--
Thanks!

Bigul

July 16, 2019 at 7:29 am #4217133

Edwin

Hi Bigul,

Thank you for your troubleshooting. I see what you mean.
As you advised I can create a page and translate it when logged in as editor. I also tried editing the translation of your test page as the original editor. That does not work.

So when a page/or post is translated by an user that page/post cannot be translated by another user except when that user has administrator rights. Correct?

That leads me to the question; how can I change the user for those translations?
Can I edit that from the WP dashboard or even through phpmyadmin in the database?
I really hope that I don't need to redo the translations.

Looking forward to your reply.

Regards
Edwin

July 16, 2019 at 5:52 pm #4223069

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Edwin,

Thank you for the updates. This not happening because of the permission, but avoid two Translator translating a Post/Page at the same time. As a workaround please try the following steps after a site backup and let me know your feedback.

1) Visit WPML>>Translation Management
2) Choose a Page from the Translation Management Dashboard list(make sure the translation is completed for the page to avoid losing the translation)
3) Send the Page for translation to translation basket
4) Visit WPML>>Translation Basket
5) Send the Job for translation to the editor user

Please check the following documentation for more details.

https://wpml.org/documentation/translating-your-contents/#using-translation-management

--
Thanks!

Bigul

July 17, 2019 at 8:57 am #4227895

Edwin

Hi Bigul

It has not been as straight forward as I expected but I have been able to assign the translations to the proper user.
Some pages worked fine and translations could be saved straight away. On some I had to check the translation as completed but could not. After removing the translation and placing it back I could mark them as complete.
On one page, Tipps, some images where missing and I had to deactivate the translation editor for that page and place the images again. Very strange.
Now all the pages can be edited as expected by the editor user. So thank you very much for your help.

That leaves one question; why should the Translation Editor be used anyway?
I followed the instruction on translating pages build with Beaver Builder. But it seems to me that translating pages with BeaverBuilder is far more user friendly. I mean, why edit pages in the main language in Beaver Builder and having to use Translation Manager for the other language.
So why shouldn't I use Beaver Builder for all the languages? Or is that a question for the developers of WPML

Again thank you for your help.
Regards
Edwin

July 17, 2019 at 4:33 pm #4232215

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Edwin,

Thank you for the updates. The WPML Translation Editors(Advanced and Classical) is using for the easy translation of Page Builder contents. Please check the following documentation for more details.

https://wpml.org/documentation/translating-your-contents/page-builders/

We can also disable Translation Editor for the Page/Post. Please check this article for more details - https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

--
Thanks!

Bigul

July 18, 2019 at 6:45 am #4235389

Edwin

My issue is resolved now. Thank you!