This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How can I translate contact form 7 placeholders?

Solution: - Contact form 7 Documentation: https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

- The solution for the client in this ticket: https://wpml.org/forums/topic/translation-of-placeholders-and-button/#post-4314803

This topic contains 11 replies, has 2 voices.

Last updated by geoffroyD-7 2 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 19, 2019 at 10:32 am #4245777

geoffroyD-7

Hello,

I have translated some contact forms but I noticed that the placeholders and the button text do not appear in the translator. All the other items are translated properly.

My question is: where can I find the settings for this? I can't find them in WPML>settings>custom fields translation and in WPML>settings>Post types translation the contact form 7 is showed as translatable and locked.
I also can't find any settings in the contact forms 7 plugin.

Can you help me find where I can put these settings so that I can translate all fields of my form?

Thank you,
Josephine

July 19, 2019 at 3:37 pm #4247189

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

The way to translate those strings really depends on how they have been implemented in the code.

1. Can you please let me know if you tried to go to WPML > String Translation and search for any of the words in those sentences?

Here is some very helpful documentation on how to use the String Translation plugin:
https://wpml.org/documentation/getting-started-guide/string-translation/

If it's not there, it could help if you scan the plugin/theme that's generating the strings and then go back to WPML > String Translation and see if the strings show up:
https://wpml.org/documentation/getting-started-guide/theme-localization/

2. If you can't find it inside the WPML > String Translation, it might be added as admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If you still can't find it:

3. Please let me know what is the exact form that you are referring to (if you can give me a link or a screenshot, that would help a lot)

4. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai Apetrei

July 22, 2019 at 3:10 pm #4259137

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

Unfortunately, I can't use them as I am redirected to a /forbidden-access page as you can see in the screenshot.

Can you please take a look?

Kind regards,
Mihai

July 22, 2019 at 3:17 pm #4259325

geoffroyD-7

Hello,

Can you check if it works now?
You need to login onto the backend before being able to access the frontend.

Josephine

July 22, 2019 at 3:21 pm #4259357

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Josephine.

It seems that it worked now and I was able to access the login panel (yes, I used the same wp-admin link).

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

PS: I'm close to the end of my shift at the moment so I might get back to you tomorrow.

Kind regards,
Mihai

July 23, 2019 at 4:15 pm #4267943

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

It seems that the user you have created for me doesn't have Admin access, so I am unable to access anything on the backend, all I can do is just log into the back.

I am also attaching a screenshot.

Can you please check? The user should have Administrator rights.

Please let me know.

Kind regards,
Mihai

July 30, 2019 at 7:06 am #4305101

geoffroyD-7

Hello,

Sorry about the late reply, I was on holidays.
The user has been updated to administrator.

Josephine

July 30, 2019 at 3:38 pm #4309343

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Josephine and welcome back from the holidays.

No worries on the late reply 🙂

I checked the user and the permissions are ok now.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

July 31, 2019 at 1:38 pm #4314803

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Josephine!

I think this is the place where you should edit the form fields placeholders:
hidden link

What I did is this: I went to the WordPress backend, changed the top-flag to French, then I went to the contact form tab where you have all the forms and I clicked "Edit" on the translated form that you are using.

I am also attaching a screenshot.

Please let me know if this solved your issue or if you still need help. 🙂

I will be waiting for your response.

Kind regards,
Mihai

July 31, 2019 at 2:32 pm #4315369

geoffroyD-7

Hello,

Thank you for your answer.
I would have liked to avoid having to change them within the contact forms and change them directly in wpml.

However, when I create a complete new form, I can change the placeholders in wpml. So I will solve my issue like that. Thank you for your help!

Josephine

July 31, 2019 at 3:37 pm #4316205

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Yes, it should normally work exactly as you explained but I don't know why this is not happening with the current form - it might be something specific to that form (maybe there was a server hiccup when it was created or something like this and probably something in the database was not written properly).

I am very happy to see that you managed to accomplish the translation process that you prefer by creating a new form.

Can you also please mark this current ticket as resolved, too?

And please never hesitate to get back to us whenever you need more help with WPML! 🙂

That's why we are here in the first place.

Kind regards,
Mihai

August 1, 2019 at 7:15 am #4319205

geoffroyD-7

My issue is resolved now. Thank you!