This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I did not succeed in translating the portfolio slug from German (default language) into English.

Solution: I can see that your are using 'Custom Post Type Permalinks' plugin to create the permalink structure for the Portfolio CPT. Unfortunately this plugin doesn't allow to translate the slug in the URL as it's printed as it is.

I recommend you to contact the plugin's authors and let them know about this issue. They should be able to provide a solution.

Relevant Documentation:

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 28, 2019 at 3:35 pm #4475591

peterW-44

Dear support team,

I did not succeed in translating the portfolio slug from German (default language) into English.

The URL structure of my subpages is as follows:

German:
hidden link

English:
hidden link

Instead of "sehenswuerdigkeiten", in English it should read "sights".

I added the English translation of "sehenswuerdigkeiten" in the WPML settings (see the attached screenshot). However, the English URL did not change accordingly.

What have I done wrong?

Thanks for your support!

Peter

August 29, 2019 at 2:06 pm #4481639

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.

Note: Deactivate all plugins and themes that are not related to the portfolio functionality.

- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

August 30, 2019 at 3:26 pm #4488165

peterW-44

Dear Carlos,

unfortunately, that did not work out. After having deactivated all plugins and having switched to a WordPress default theme, I could not access my subpages anymore (like Venetian Lagoon etc.). I got an error message that this page needs the Avada theme to be displayed. So, I cannot tell you, whether the portfolio slug has been translated into English or not.

Any other ideas to resolve this issue?

Thanks!

Peter

September 3, 2019 at 2:25 pm #4505217

peterW-44

Dear Carlos,

I followed your instructions and tried to migrate the website twice. For whatever reason, migration failed both times (see the screenshot attached).

What else can we try?

Peter

September 3, 2019 at 7:11 pm #4507047

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Peter,
Thank you for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

September 4, 2019 at 1:55 pm #4511563

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I can see that your are using 'Custom Post Type Permalinks' plugin to create the permalink structure for the Portfolio CPT. Unfortunately this plugin doesn't allow to translate the slug in the URL as it's printed as it is.

I recommend you to contact the plugin's authors and let them know about this issue. They should be able to provide a solution. You can also invite them to join our Go Global Program: https://wpml.org/documentation/theme-compatibility/go-global-program/ where they can get in touch directly with our compatibility team.

Thank you very much for your understanding!
Best regards,
Carlos

September 5, 2019 at 7:12 am #4516015

peterW-44

Thanks a lot for your help, Carlos. I will get in touch with the CPTP team to find a solution.

Peter

September 5, 2019 at 9:12 am #4517421

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Peter,

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos