This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Dennis 8 months ago.

Assigned support staff: Dennis.

Author Posts
February 11, 2019 at 2:39 pm #3183525

saeedS-3

Hi,
I got filter on my website, which is filtering custom post types with AJAX.
It works proper with default language. But when i swich to other language, and i'm trying to filter custom post types, i see search results in default language (not in translated).
So the page is in translated language, except the search results, which are in default language.
How can i fix it?

February 12, 2019 at 9:04 am #3187408

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please try to enable Ajax filtering at WPML > Languages > Language filtering for AJAX operations. Then click 'Save'.

https://wpml.org/documentation/getting-started-guide/language-setup/enabling-language-cookie-to-support-ajax-filtering/

Does it help? Please let me know.

Kind regards,
Dennis