Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I want to translate the social links of my Avada theme.

Solution: - Erase the social links strings. - Go under "WPML -> Theme and plugins localization". - Make sure that "Translate by WPML." is active. - Scroll down to "Strings in the theme" and click on "Scan the theme for strings". - Once you followed the above steps go under "WPML -> String Translation". All strings available for translation should display in the table you see there.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/string-translation/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Andrés 5 years, 2 months ago.

Assigned support staff: Andrés.

Author Posts
July 8, 2016 at 11:59 am #949042

massimoS-6

If you check out this page:
hidden link

you cansee at the bottom of the page the various social links like "share on facebook", "tweet this product" and so on.

Those strings have been translated into slovenian already, using the string translator, but still they are showed in english. Why?

Thank you!
Max

July 8, 2016 at 1:23 pm #949165

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Max,

Welcome to WPML support forum.

1. Could you please update your Avada theme version?

2. Could you please verify that the following option is activated:
- Go under "WPML -> Theme and plugins localization".
- Make sure that "Translate by WPML." is active.

3. If this is the case, then:
- Could you please erase the problematic strings.
- Go under "WPML -> Theme and plugins localization".
- Make sure that "Translate by WPML." is active.
- Scroll down to "Strings in the theme" and click on "Scan the theme for strings".
- Once you followed the above steps go under "WPML -> String Translation". All strings available for translation should display in the table you see there.

Do you see them? If yes, all you need to do is click on "translations" next to each string you want to translate and enter + save your translations.

Documentation:
https://wpml.org/documentation/getting-started-guide/string-translation/

Best regards,
Andrés

July 8, 2016 at 1:36 pm #949232

massimoS-6

It worked! Thank you Andrès!

July 8, 2016 at 1:39 pm #949253

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Great!
Have a nice weekend ! 🙂
Andrés