This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 3 voices.

Last updated by George Botsev 3 years ago.

Assigned support staff: George Botsev.

Author Posts
September 28, 2016 at 7:04 am #1103356

marcH-8

Hi (George),

besides the problem that the settings changed from "use wpml string translation" to "not use" when updating string-translation, I have a problem with translating some words.
I HAD translated these words and they showed up, but now, after updating wpml (and there were frequent updates in the last weeks), some translations do NOT show up anymore.
Please go to my german page at: hidden link
and scroll down to the footer. On the left is the address. This is a theme widget. I have translated all of the theme widget (it's called Porto widget according to the Porto theme). AND.. it worked before. Now, as you can see "Address", "Phone" "Working hours" are not translated. Yesterday, after translating them again, at least "Address" showed up in German, but today even this is gone again. On the Italian page (hidden link) it was also translated partially, today NOTHING!!! So, there are some automatic changes!!! If you like, I can give you wp-admin access and you can check. BUT... I am moving the site to a new domain in the next 1-2 days, so, if this persists, we can do it in 2 days. Thanks.

September 28, 2016 at 3:07 pm #1103914

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I am going to assign this ticket to George and he will be happy to assist you further.

September 29, 2016 at 9:12 am #1104431

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello, I visited your site, and yes - this looks very strange.
So the issue is only with that widget?
It is very strange, but sometimes the widgets are being cached in WordPress.
I would suggest you to try and clear all possible transients on your site. This has the possibility to help to some extent, but it is not guaranteed. You can use a plugin for that - a very handy tool - https://wordpress.org/plugins/artiss-transient-cleaner/

However, I feel the need to investigate the issue further, so I would like to take you up on the offer to provide a temporary access.

I understand that you are going to move the site, it is not a problem for me to wait for two days until the process is complete.

You will find the form for securely providing access to us in your next reply, I am enabling it now. Please if you don't see the form - do not add the credentials and ping me again.
As I said above - you can add this details when you have migrated your site, and it can wait - if it is not a problem for you.

October 7, 2016 at 9:27 am #1110584

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Yes, I see the problem.
I tried the ftp credentials, but they are not working for me.
I need to get the theme in onder to debug the issue.
To do that, I can use the plugin Duplicator - let me know if you allow me to install and use that plugin to get a clone of your site.

October 7, 2016 at 3:09 pm #1110907

marcH-8

I reset the password to the one I gave you. It should work now. Sure, you can install the duplicator (if it's not installed yet by some other wpml support).

October 10, 2016 at 11:41 am #1111939

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello, sorry for the late reply.
Yes - I see the plugin Duplicator installed.
However for some reason, I am unable to create a package with it.

I also tried to access the FTP - but I might be blocked via some access list - the host is not responding to me when I try to connect.
I just need to get the theme in order to help you with the issue, but I am unable to do that.
Could you perhaps archive only your theme and send it to me via dropbox or google drive?

I am enabling the private reply so that you can share the link.

October 10, 2016 at 3:51 pm #1112224

marcH-8

uhh... I think it's because of cloudflare!! I think for FTP you have to use the IP address instead of the domain name. IP is: 217.160.3.136

try it with this. otherwise I have to check and/or disable cloudflare.

October 11, 2016 at 7:10 am #1112543

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Yes, this was the problem.
I finally managed to connect via FTP and now I am downloading your theme in order to reproduce and try to fix the issue.
I will get back to you as soon as I have finished downloading and tested the theme.

October 11, 2016 at 8:50 am #1112616

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Okay, I found the issue and fixed the problem.
There seems to be a different way on how to translate the values for this widget.
I managed to translate it for your site by selecting the text in "Translate strings in admin screens" in WPML > String Translation.
For more information - check my screenshot.
Once I selected that, I translated it as any other string in String Translation and it is now working on your site.

October 11, 2016 at 2:16 pm #1112960

marcH-8

Hi George,

I didn't understand it completely, but I am glad you found the problem. So, is it a wpml plugin problem or configuration problem or user problem? Can I now translate it with string translation as I am used to? And do I have to select all the other options as well (phone etc.) in order to translate them? Or is the problem fixed now for good?

I see that the "office hours" have been translated now, but phone and address are still the same: hidden link
So, I have to click also the other things in this screen? hidden link

thanks, marc

p.s.: AND.. how come that this has been working before and it stopped working?? I HAD translated it and it showed up in the translated language before!!! Is it due to a plugin update?

October 11, 2016 at 3:03 pm #1113008

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

It is hard to classify this problem if it is a user problem or configuration problem.
I guess something got updated at certain time, and caused the issues - but I am not sure what exactly - as the values for strings could have been cached for a long time - especially if not updated.
You can translate the phone and adress as the same way as I translated the working hours.
Please do differentiate between setting -2 and setting -3 (I made adjustments in setting -3).
This usually means another instance of the widget.
You might need to go to -3 - and there you can select whatever you need to be translated, and push the button at the bottom of the page to register it (depending on your server load you might need to push it more than once - because you have a lot of options).

Please also differentiate between _label and the value. If you wish to translate the phone number - select the value, if you wish to translate the label - then select the field with the label.

For your last question - as I said in the beginning - it was working because there could have been a compatibility class that made it work - e.g. something in your theme that registered the strings (as you see, you have now other strings with the same value, but with different context, domain and name) and the rest was cached until string translation cache was purged (possibly when updated WPML String Translation or if deactivated/re-activated the plugin).

October 11, 2016 at 4:03 pm #1113077

marcH-8

George, I still don't get it. I have translated all the values, but NOT the labels. However, the labels are named for example: "Working Days/Hours Label" and I think this is what the admin sees. It's not what is displayed on the site. Because I have translated only the value, not the label, as you can see here: => hidden link
And this works. I have clicked also the other values (phone, address, email, contact us) and they are all translated, but don't show up. I have clicked them in -3 settings, where you clicked the Working Days. Since Working Days works now, the other values should also work... but they don't.
However, I have also clicked the "Labels" in the admin strings, but I think this is different to the "labels" you see on the string translation screen. Anyway, almost all clicked and translated and it doesn't work...

October 12, 2016 at 9:13 am #1113550

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Your screenshot shows categories and not the widget.
Well, it seems that the theme author has not beeing cooperating with our compatibility team when they tried to contact him.
As a workaround, I would like to suggest you to try and follow this guide: https://wpml.org/2011/03/howto-display-different-widgets-per-language/
It should finally work and display your widget properly where needed.
And unfortunately, your theme widgets are not entirely compatible with WPML.
If you wish, you can ping your theme author for fixes - since he is not willing to cooperate with us for fixing this.

October 12, 2016 at 3:39 pm #1113905

marcH-8

sorry, was a wrong screenshot. That's the correct one: hidden link

For the plugin, this is not useful for me, it translates the content of the widget, but not the labels!! I could translate the content with the widget logic plugin I have installed, but I need to translate the labels. Sorry that the theme author is not cooperative... 🙁
I can ping him, but I would need to know exactly what to tell him. Which code to change and where.
I will continue to try to translate the widget.. 😉
thanks.

October 13, 2016 at 9:20 am #1114444

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

The method that I suggested should work for you.
In the widget, you CAN enter both the label and the value, so in essence, you will have 2 separate widgets with different values - this is bulletproof way