This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Riffaz 2 months ago.

Assigned support staff: Riffaz.

Author Posts
August 3, 2019 at 4:47 pm

Kirstin

I am trying to:

Edit the english version of the homepage.

Link to a page where the issue can be seen:

hidden link
I can provide you with an account to access my WP backend if needed.

I expected to see:
The editor should open so I can translate the content.
Instead, I got:
The following error message: The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

August 4, 2019 at 7:40 am #4335715

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Please fix these two and check again: hidden link

Your hosting allows you to use up to 256 MB of memeory but you are using only 40 MB if WP Memory Limit.

Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

And, contact your hosting support and ask them to increase the MaxInputVars to 10000

After making these changes check the issue.

Let me know how it goes.

Regards,
Riffaz.

August 4, 2019 at 9:10 am #4335965

Kirstin

Hi Riffaz,

Thx for your quick reply! I changed both settings and restarted apache. I verified that the new config is active. Unfortunately, the issue is still there...

Any ideas?

Thx,
Roeland.

August 5, 2019 at 5:18 am #4337883

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Now, we have to dig more.

Could you please add me your PHP error log? WordPress includes a debug mode which helps reveal PHP problems.

To enable it, open your wp-config.php file and look for

define('WP_DEBUG', false);

Change it to:

define('WP_DEBUG', true);

In order to enable the error logging to a file on the server you need to add yet one more similar line:

define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

define( 'WP_DEBUG_DISPLAY', true );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

Please note that you’ll see everything, not only related to our Plugins.
This will most likely include messages from other plugins, your theme and sometimes even WordPress core. The messages appear all over the place.
Sometimes they appear right on top, but they can also appear in the middle of the page.

DOC:
https://codex.wordpress.org/Debugging_in_WordPress

Please report me the errors you are seeing.

Kind Regards,

August 11, 2019 at 7:48 am #4376691

Kirstin

Hi Riffaz,

After turning debugging it became clear that the issue was located in the Karma Builder plugin that ships with the Karma theme. After deactivating that plugin the translation worked. This is OK for me because I don't use the builder anyway. It might be an issue for others who are using Karma and WPML, so this is definitely something that is worth a deeper investigation.

This was the error:

[04-Aug-2019 11:57:24 UTC] PHP Fatal error: Cannot redeclare replace_invalid_byte_sequence() (previously declared in /mywordpress-dir/wp-content/plugins/karma_builder/karma_builder.php:8994) in /mywordpress-dir/wp-content/plugins/karma_builder/karma_builder.php on line 8994

Best regards,
R.

August 11, 2019 at 2:58 pm #4377075

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for letting us know this and great it works now.

As per the error message they have to make a small change in their code to fix this issue.
We will let them know this when check the compatibility and goglobal program.

Regards,