Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 20, 2020 at 12:43 pm #6838635

zuzannaR

I have written a blog post that I plan on updating quite recently. The blog post has some images. Alt text of the images appears correctly - it's in English in the primary language of the website and in Spanish in the secondary language (translation).
The issue appears when I update the English (original) content. When I update it and update the Spanish translation, the alt text of the images on the Spanish website is automatically reversed to English.
I need to do the following tedious steps every single time to have the alt text in Spanish:
1. Switch the language of the WP Dashboard to Spanish
2. Edit the post in WP editor
3. Incert once again all the images into the Spanish post.
4. Save the post.

ONLY THEN the alt text of the images on the translated website will appear in Spanish.

Why is this happening? What can I do to not have to reinsert the images over and over again?

August 21, 2020 at 1:55 am #6841717

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting our support service. Do you see the same issue if you translate these texts right in the media library? I mean the following:

1 - In yourWordPress Dashboard > Media click to view your media items in the secondary languages (spanish), then click to edit the media item where the issue happens and translate the media description.

2 - Then, click to edit the post in the default language and make an editing as you did to replicate the issue and let me know if you still see the same issue.

Thank you for your collaboration, have a nice day.

August 22, 2020 at 4:48 pm #6851539

zuzannaR

Hi Marcos,

Thank you for looking into it. I'm afraid the issue is still there.
Here's what I did:

1. I added new image to the Media Library
2. I translated the image in the Media Library.
3. I have added the image to the English post (main language)
4. I've updated the Spanish (secondary language) translation in WPML
5. I saved the post
6. I went to the published post and checked the alt text in Spanish - it is still in English.

Just to clarify - I CAN SEE the translation in the Dashboard. The issue is that when I'm on the Spanish website and I copy the image, the alt text isn't traslated.

I've recorded a short video to show you what I mean:
hidden link

August 24, 2020 at 6:03 pm #6862089

zuzannaR

Hi Marcos, just wondering if you had a chance to watch the video I pasted in the previous post to see the issue I'm having. Thank you.

August 24, 2020 at 6:31 pm #6862209

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided clarifications and sorry for the bit of waiting here due the weekend. Indeed although your image is being translated properly using the WPML Media Translation those translations are not appearing in the frontend and we'll need to proceed with a detailed investigation here.

I would appreciate to give a detailed look at your WordPress Dashboard so I can check settings in order to understand the cause of this issue, for that please consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 26, 2020 at 8:02 am #6874583

zuzannaR

Marcos, it looks like it works fine now 🙂 Maybe it was some temporary bug?

Just to make sure I understand the process of translating the images, can you answer these questions?

1. Is it better to translate the images in the Media Library before inserting them into the blog post? Or is the order irrelevant?

2. Once the images are translated in the Media Library and inserted into the post, will WPML translator ask me again to translate them in the Translator Manager?

August 26, 2020 at 5:08 pm #6879521

zuzannaR

Hi Marcos, please disregard my previous message. The issue is still there, unfortunately 🙁
I don't see the private form to provide you the credentials to log in to my website. Can you please let me know how to do it?

August 26, 2020 at 7:04 pm #6880169

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. The next replied is marked as private, so, you can safely send the WordPress Dashboard and FTP access details. Thank you for your collaboration and continued patience, have a nice day.

August 27, 2020 at 4:49 pm #6888187

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look at your WordPress Dashboard and noticed the translation for the mentioned post are showing the images related text in english (see attached screenshot).

In fact the attached media files are translated properly from your WordPress Dashboard > WPML > Media Translation but for some reason the translated content for the 'core/image' blocks in the Translation Editor seems to be overwriting the media translations you made.

How are you editing your content in the default (english) language? During these editings do you replace the media files in the content? When making these editings are you clicking to update and edit the translation using the WPML Translation Editor? Please, note if you click to edit the translation content to edit your images or replace them using the WordPress standard page/post editor, the changes you made using WPML Translation Editor will be lost.

Please, let me know these details and if editing the translations using the Translation Editor only, resolves your issue. Have a nice day.

August 27, 2020 at 5:15 pm #6888267

zuzannaR

Hi Marcos,

My workflow looks like this:
1. I create the English post and insert all the necessary images and make sure they have alt text in English.
2. I then go to WPML editor (the one from your screenshot) and translate all the content there.
3. Later, at some point, I decide to modify the original English text (not images - just text).
To do so, I open WP editor and do it there. I don't replace the media - just modify the text. Once I'm done changing the text, I click on the "Update" button in the top right corner to save the changes.
4. To later update the Spanish translation, I go to the WPML Translator Editor (the one from your screenshot) and make the changes there.

Am I doing it correctly? I think I am.

August 29, 2020 at 3:25 pm #6899499

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Yes, the workflow you described is correct. Do you find issues with this workflow? Are you still having issues with the images texts translations? Please, let me know, have a nice day.

August 29, 2020 at 3:40 pm #6899545

zuzannaR

Hi Marcos,

Yes, I still have the same issue I described at the very beginning - it hasn't been resvoled yet. I simply described you my workflow, so that you see how I work.

Now that you know how my workflow looks like, can you please look into my issue and let me know how it can be fixed?

Thank you!

August 31, 2020 at 11:28 pm #6911079

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the clarifications. I would need to proceed with a detailed investigation, in order to determine what's the cause for this issue. For that, please consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

September 3, 2020 at 7:54 am #6932169

zuzannaR

Hi, I'm currently away from my computer and can't duplicate the website. I'll do it when I'm back, on Thursday 10th Sep. Thanks!

September 3, 2020 at 5:42 pm #6937449

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. No worries, once you are done, please let me know and we'll proceed with the debugging process. Have a nice day.

The topic ‘[Closed] Translation of the images ALT TEXT automatically switches to the source language’ is closed to new replies.