This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Alejandro 1 month, 4 weeks ago.

Assigned support staff: Alejandro.

Author Posts
August 23, 2019 at 6:45 am #4444327

timofeiP

Hi

I am trying to display products sorted by custom "Brand" attribute. It works well in original language, but I see just empty product's page when it goes to product's translation. I only see Brand Name, beside "Clear Filters" link, and no filtered products appear.

I tried to make attribute translation in two ways:

1. Dashboard > Products > Attributes > Configure Terms
2. Dashboard > WooCommerce > WooCommerce Multilangual > Attributes > Brand > Copy to All Languages. Then I clicked on "Synchronize attributes and update products variations".

After setting it up, I updated Permalinks via WordPress Setting > Permalinks also.

It does not work in any ways.

However when I am trying to sort translated products by "Brand" in the Dashboard ( Dashboard > Products > Attributes > Configure Terms > click on the link in "Count" column), I can see my products for the 2nd language.

Link to a page where the issue can be seen:

hidden link

hidden link

August 23, 2019 at 11:42 am #4446501

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello and welcome to WPML's support forum.

Please check the Product Option (En).Jpeg screenshot you uploaded and change the option you see there from "make products appear as translated" to "make Products translatable" and proceed to save and translate or duplicate the products, otherwise they will not appear in the front-end.

That's one of the only restrictions of the option currently set in the products.

Filters will not work if the product doesn't really exist in the other language.

Try that and let me know how it goes.

August 23, 2019 at 12:43 pm #4447251

timofeiP

Hi Alejandro,
and thank you for the reply.

I have translations for all products belonged to those "Brands".

I followed your advice and have changed the setting you mentioned, via WPML > Settings > Taxonomies Translation section.

Unfortunately it does not helped to solve the problem.

I've noticed a one more thing, that I think may be related to this issue. On WooCommerce Troubleshooting page, I have following information appeared:

Sync variables products:
Duplicate terms ( please select attribute ): [Brands] 2 left

When I am clicking "Start", button it become:
Duplicate terms ( please select attribute ): [Brands] 0 left

But, after the Troubleshooting page got refreshed, I still see the same value:
Duplicate terms ( please select attribute ): [Brands] 2 left

What could it be?

Screenshot attached

Thank you

August 23, 2019 at 3:23 pm #4448413

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

The problem is not with the taxonomy, it's with the actual product and i'm sorry if i wasn't clear enough about it, last time.

Let's try something else:

Go to WPML > Settings > Post Types Translation > Find Product and set it to the far-left option (set products as translatable - only show translated items).

Then proceed to duplicate or translate each product: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Then try to check if it appears now.

The restriction is with untranslated products and filters. Filters can't filter something that doesn't exist thus it can't find nor it can filter them until they exist in the language where they are being filtered.

I hope i was clearer now.

Regards.

August 23, 2019 at 5:24 pm #4449107

timofeiP

Hi,

Thanks you.

As I already mentioned above - all of my products have translated pages. Screenshot "Translated products.jpg"
I have enabled "far-left option" option as well. Screenshot "Products.JPG".

Unfortunately, all of these methods doesn't help.

At the moment I found out what the problem already. I have translated SHOP page and its SLUG into Thai language:

/th/ผลิตภัณฑ์ของเรา/

So, when I call SHOP page with any parameters like:

/th/ผลิตภัณฑ์ของเรา/?filter_brand=claracel-th
/th/ผลิตภัณฑ์ของเรา/?per_page=24

I can't see any products on the page.

After renaming SLUG with latin characters everything works well:

/th/products/?filter_brand=claracel-th

I am not sure is this problem in WPML or with my current Theme. I also post a topic on the theme support forum.

August 23, 2019 at 5:50 pm #4449239

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Oh, that's interesting. try to do something:

Briefly change the slug of the shop into thai again and then change the theme to twentynineteen and see if it works without issues. if it does then the problem could be because of the theme (maybe and incompatibility issue). if the problem is still there then the problem is probably on WPML.

If this is happening on a live site (it looks like it), then you can use one of our sandboxes sites: hidden link

in here all you have to do is configure WPML, then translate a few products with the attribute you are using on your site and then translate the shop slug on the site with thai characters.

if that replicates your problem then the problem is with WPML entirely. if instead it doesn't, upload and activate your theme and try again and see if that breaks the site.

I strongly suggest the sandbox method because you'll be isolating the entire issue and it will also allow us to send the case to our developers if needed.

Regards (and sorry about missing the part where you stated you had already translated the products!).

The topic ‘[Closed] Translation of WooCommerce Brands attribute do not work’ is closed to new replies.