This thread is resolved. Here is a description of the problem and solution.

Problem: Translation of WooCommerce product-slug fails

Solution: Client deleted the translation for the failing product page url, and recreated it from scratch, he also re-saved the permalink structure.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 2 years, 5 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
January 17, 2018 at 10:08 am #1487110

Alex Paulsen

Hello,

I opened a support ticket on this subject just before Christmas. Here it is:

https://wpml.org/forums/topic/where-to-translate-woocommerces-product-slug/

I have tried to save my Permalink Settings as suggested in this previous support ticket, but this has not solved my problem. So I still need support on this issue.

This problem only occurs with the Italian product page translations. Other langauges on the website work as expected.

Thank you.

BR,
Alex

January 19, 2018 at 2:08 am #1489308

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

1.- Could you tell me if this issue persist in a minimal setup?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

January 19, 2018 at 8:41 am #1489484

Alex Paulsen

Hello,

1. - What do you mean by minimal setup?

2. - That is strange - I should've already adjusted the memory limit with this code from my current wp-config.php:

/** Custom */
define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Is it not working as it should?

Best regards,

Alex

January 19, 2018 at 9:57 am #1489666

Alex Paulsen

Hello again, Carlos,

I need to moderate my previous reply. It seems that saving the permalinks earlier did in fact solve most of the problem. I have probably been fooled by a simultanious issue with the cache.

This issue is now only appearing on one specific single product page. I've tried clearing the cache completely and updating the translation twice with no success. I also tried deleting the current translation and re-creating it through the translation module, which didn't work either.

Any advice on correcting this?

Thank you

Best regards, Alex

January 19, 2018 at 12:49 pm #1489869

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

I'm glad to hear that the issue is reduced to just one single product.

1.- Could you provide the steps to reproduce the issue in this case?

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Note: Minimal setup is when all plugins are deactivated except WPML plugins and a default WordPress theme is active.

Kind regards,
Carlos

January 29, 2018 at 7:24 am #1499609

Alex Paulsen

Hello,

Thanks for your support. I've managed to solve the issue myself. I not exactly sure why it worked, but I deleted for translation for the failing product page url again, and recreated it from scratch. After that, everything turned out fine.
I suspect this problem was somehow cache-related, as I've been having quite a number of hick-ups from the site, where changes are not immediately displayed on the live site.

What is WPML's experience with the WP Fastest cache plugin? Do you have a cache-pugin recommendation with regards to the WPML-setup? Because I think my next step is to find a better cache solution.

Have a nice day

BR,
Alex

January 29, 2018 at 12:58 pm #1500047

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alex,

I'm glad to hear that the issue is solved 🙂

Regarding your question of a cache plugin, I recommend you to visit this link, where you will find a list of multi-lingual ready plugins tested by our compatibility team: https://wpml.org/documentation/plugins-compatibility/

Please don't hesitate to contact us if you need our help in the future with WPML. We ill be more tha happy to help.
Kind regards,
Carlos