Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.64 hours from now. Thank you for your understanding.

This topic contains 10 replies, has 2 voices.

Last updated by Alejandro 2 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
March 23, 2021 at 6:29 pm #8383039

jennaS-3

I have a site where main lang is english, secondary is french.

ISSUE:
I had an issue (video: hidden link) where i tried to update the french side as i normally do, but the edit boxes were all small strange sizes and some fields (like woocommerce variables) were no longer showing the translation and instead had nothing on the right side. On the front end though of the site, the translations were there.

I then created a staging environment, updated everything form core to plugins and themes. Tested again and this time it looked proper. Now the issue is that when I try to click save and return to the main english page, it just reloads the translation page. I did notice the content is saving, but it is annoying to have to double check that it actually did and then have to reload the main translation edit page manually. Here is a video of this issue: hidden link

Apologies on video quality but should be good enough to understand

Link to a page where the issue can be seen:

Live site without updates: hidden link
Staging Site with updates: hidden link

Note* debug info is from the staging site where all is updated

Please let me know if you need any more details or login to help

March 24, 2021 at 2:21 pm #8390621

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi there!

1) Let's start by meeting WPML's minimum requirements:

Please add the following code in your wp-config.php file, right after the database information lines of code:

define('WP_MEMORY_LIMIT','128M');

2) ❌ Before proceeding please make a full website backup! ❌
Go to WPML -> Support -> Troubleshooting
Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix post type assignment for translations"

Regards.

March 24, 2021 at 3:23 pm #8391113

jennaS-3

Hi Alejandro.
I followed your instructions but still the same issue where it reload the page instead of going back to the main language. I added the memory limit code into the config, but checking in my WPML support section, it shows that i actually have 512M for my php and 128M for wordpress. See the image. Thank you and please let me know

Screen Shot 2021-03-24 at 11.18.47 AM.png
March 24, 2021 at 4:02 pm #8391705

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

1) Can you check if the same problem happens when:

- You disable all the plugins except WPML
- The theme is set to be a default WordPress one (like twentytwentyone)

If the problem disappears then,

2) Can you check if your input vars settings are too low? please open the inspector by right-clicking the translation page from the video and then adding this code in the "console" tab

jQuery('input').length;

You have quite a high setup, and in the video, the page didn't seem to be using more than 10.000 inputs, but let's see what it says.

3) Please follow the instructions mentioned on this page: https://wpml.org/documentation/support/debugging-wpml/

Try to recreate the problem once you have added those lines to your wp-config.php file and then go to your installation's wp-content folder and find the "debug.log" file that should've appeared by now (it will appear if it encounters an error in your server).

Then, upload that file into a storage platform of your choosing (Google Drive, Dropbox, etc) and send me the link (make sure it's set as "public" otherwise I won't be able to access its content) so I can download it and take a look at it, and determine where to go from there.

Regards.

March 24, 2021 at 5:16 pm #8392781

jennaS-3

1. I disabled everything except WMPL and woocommerce (given these are products i need it still enabled). Also reverted theme to a default one. No luck and issue is the same.

I checked the inspector for jQuery('input').length; but nothing returned. Attached are the errors I did see though incase that helps. These errors showed with all plugins disabled and theme default and also with everything set normally as it was.

I'm thinking perhaps it has something to do with those errors? with tinymce

I tried the debugging but nothing came up and i didn't see an error log created. Refreshed my FTP too but not seeing anything.

I attached as well a screenshot of some fields in my wp-config file incase that helps at all?

Screen Shot 2021-03-24 at 1.14.31 PM.png
Screen Shot 2021-03-24 at 1.00.11 PM.png
March 25, 2021 at 12:02 pm #8399161

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

hm, ok can you please allow me access to a staging site where the problem is visible?

please disable all the plugins and theme and leave only WPML and WooCommerce then.

you can add the credentials in the related fields I have enabled in your next answer.

March 27, 2021 at 10:43 am #8413005

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Unfortunately i can't see the problem as you can check here: hidden link

Can you let me know if I did something wrong or if the problem went away?

March 27, 2021 at 9:54 pm #8414781

jennaS-3

Thank you for the great video. Strange though that you seam to have the english page reload after save & close but for me it never returns to the english page. Here is a video, i added a the end showing the inspector. Any ideas? Thank you for your time. I also cleared all caches before trying.

hidden link

March 29, 2021 at 8:25 am #8419919

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I asked a colleague that uses safari and MAC to test this for me, because i suspected that it was a browser issue, yet it worked on his end as well.

he has the following versions:
- Safari Version 14.0.3 (16610.4.3.1.7)
- MacOS Version 11.2.3 (20D91)

Can you try it on a different browser, chrome, perhaps?

and try it with my user and yours as well to see if the problem is happening on a user level.

let me know how it goes.

March 29, 2021 at 3:20 pm #8423887

jennaS-3

Hi Alejandro,
So it does seam to be a browser issue. I have the issue in firefox on mac v87.0 (64bit). The browser is up to date so maybe something to report on your end?

For now i will use chrome as i don't have the issue. Thank you for your help!

Jenna

March 30, 2021 at 8:17 am #8428487

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I tested this on firefox with the same version and asked the same colleague that provided the last data to check it in safari, opera, firefox and chrome and it worked everywhere on his end as well.

You can see what i did here: hidden link

So the problem seems to be something on your pc, maybe a temporal file or a security setting in your pc or browsers?