This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 2, 2019 at 9:20 am

rosieN

I am trying to:
Have translated pages for each of my pages on the website. I am using cornerstone and have built the translation pages as well as done all the translations. When editing in cornerstone, all of these changes and translations show in German. However when visiting the website as a user, none of these translation updates are showing. The title is the German title, but none of the words that were translated are actually updated - they are still all in English.
Link to a page where the issue can be seen: hidden link

I expected to see:
The German side reflect publicly what it shows on the back end.
Instead, I got: Pages that aren't updating the translations publicly.

July 2, 2019 at 10:18 am
July 2, 2019 at 10:35 am #4125749

rosieN

Is this where I reply now? The migration is complete

July 2, 2019 at 10:44 am #4125847

rosieN

Where do I contact you again??

July 2, 2019 at 10:49 am #4125913

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You can post replies here, we will continue here in the forum.

I will test the issue and will respond to you soon.

Thanks

July 2, 2019 at 10:50 am #4125921

rosieN

Okay thank you

July 2, 2019 at 12:19 pm #4126659

rosieN

Hey 🙂 - just wondering if there's some kind of timeline? Thanks!

July 3, 2019 at 4:12 am #4131683

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I debugged the issue and noticed that it's happening when using the manual editor, but it's not happening on a fresh new page, could you please try to replicate the issue on a fresh new page and let me know if you can confirm the issue?

Further, If I enabled translation editor and translate the content, the content is showing properly, the translation editor is the recommended editor, so I request you to follow the below steps and let me know if this helps:
- Go to the default language post
- Set the editor to classic translation editor for the post-https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/
- Translate it from translation editor and see if that helps.

Look forward to your reply.

Thanks