This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Ricardo Alday 1 year ago.

Assigned support staff: Ricardo Alday.

Author Posts
September 3, 2018 at 1:49 pm

anD-4

I am trying to:

When i open wpml translator to translate the motorcross page:
on the right side: all the translation boxes are shuffled.

this problems is on one page:
hidden link

TEST WITH PAGE MOTOCROSS OLD . --> this is a duplicate of page motocross to TEST.

September 4, 2018 at 5:29 pm #2704221

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @and-4, welcome to the WPML support Forum!

I checked the back end of your website and apparently everything is ok. Maybe the translations were done in the wrong fields.
- Does this issue occur only on this page or on all pages of the site?
- Did it start to occur after some update or installation of theme / plugin?

Please try the following(with the test page or a cloned page):
- Go to Pages > All Pages
- Change the language using the language switcher at the top admin bar
- Delete the translation
- Click on "Trash and delete the translation from the trash"
- Go back to Pages > All Pages and switch to the default language
- Create a new translation and click on the "Copy all fields from the original" button
- Save

Please let me know if it worked for you.

All the best,
Diego

September 5, 2018 at 7:23 am #2705726

anD-4

hello,

no, everything is not ok.

If you would check the french version of the site you would see that all the french text is shown correct on the website... so the translation is not filled in in the wrong boxes.

I already did create a whole new page: the motocross page, did a translation again form zero. At first everything is ok, but when we change something to the original page, and open the translation again all the boxes are shuffled...

--> Also, even when changing just a comma on one box, the translation is set to 36% complete, and we need to start all over again.

the motocross page is the only page this problem exists. it must be conflicting with something. I already tried deleting some modules but it didn't help either. So i can't find out what is is.

I already put a lot of time in this issue.
So please, i added all the login info, a duplicator copy of the website, take the time to check it thorough.

September 5, 2018 at 7:48 pm #2708600

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I duplicated the site on my local server and tested using the steps below:
- Delete the old Motocross translation (deleted also from the trash)
- Do a small modification on the "Motocross "page and save
- Create a new FR translation, translate all fields and save
>>>> So far so good, the original page and the translation work ok
- Go back to the original page, do a small modification and save
- Check the translation editor
>>> Now I can see the issue: some fields (not all) seems on incorrect order, a lot of fields are not marked with "Translation is complete"
- Fix all strings that are missing(translate the strings again), mark the translation is complete field (100%) and save
- Go back to the original page, do a small modification and save
- Check the translation editor, now only the modified strings need revision. Apparently everything is okay.
- Translate the strings and save
- Check the front-end
>>> Now it seems to work normally. If I edit the content on the default language, I just need to translate/update the modified strings. The front-end is ok as well.

Please check if the above steps are correct and reproduce them on your website. Please backup first and do so with a test page.

Another option is to use the Manual Editor to translate, instead of the translation editor:
- Go to WPML > Settings
- Scroll to How to translate posts and pages
- Select Create translations manually
- Save

Please let me know if it worked for you.

Regards,
Diego

September 6, 2018 at 2:46 pm #2711185

anD-4

hello,

i found out that the problem occurs when editing the slider. When changing that one,
- the 'translate complete bar' goes to 26%, leaving a lot of fields not checked and their translation deleted (the original language is filled in instead).
- some boxes are shuffled

So, this is a bug i suppose... can this be solved?

September 6, 2018 at 7:25 pm #2712156

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Is the slider generated by the theme or by a plugin?

In this case we need to isolate the issue and test with a clean install, to check the compatibility. I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in. I already configured WPML on this site.

Please upload the theme/plugin to this test install and setup it the same way as in your website (using the same options). After that, please create a test page to reproduce the issue. Please note that we only need the theme/plugin, a dummy content and the related functionality to test, you don't need to setup a entire website or clone your existing site.

Regards,
Diego

September 7, 2018 at 7:05 am #2713314

anD-4

the slider is generated by the theme.

i uploaded the theme and tried it in the sandbox, everything works fine...
I created a slider and a contact form: everything keeps working.
--> everything is DIVI native

In general I only have wp datepicker, conditional menus and custom facebook feed installed (next to wpml). these i only use on the other page of the website, where wpml works fine.

I already tried deleting some boxes on the motocross page, and restart translating (delete the old translation), but the problem stays...

An

September 10, 2018 at 8:35 pm #2721392

Ricardo Alday

Hi,

Sorry for the late reply.
After making a full site backup, go to WPML -> Support -> Troubleshooting, and click all the buttons on the "Clean up" section. Then try to recreate the problem and let me know if it persists.

September 17, 2018 at 10:05 am #2740609

anD-4

hello, this didn't solve the problem. I now changed the translation to manual... we will see if that works correctly

September 18, 2018 at 12:14 am #2742823

Ricardo Alday

Thanks. Keep us posted. If this thread closes before you can update feel free to open a new ticket.

Best regards,
Ricardo

The topic ‘[Closed] translation page shuffles all the translation text boxes’ is closed to new replies.