This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 2 voices.

Last updated by Itamar 8 months ago.

Assigned support staff: Itamar.

Author Posts
December 2, 2018 at 5:17 pm

yannickS-3

I have a serious issue with WPML, which is driving me crazy at the moment.

The issue appears in 'Advanced Translation Editor', but as well if we turn it off and use the 'Classic Translation Editor'.

The main language of the page is english.
There are two more languages: Chinese and German.

There is a page (=Chinese home page: hidden link), which got translated by a 'local translator' from Englisch to Chinese.
Everything worked well with the initial translation. The translation was completed and 'delivered' and the result in the Chinese page in the website (site and admin) was like expected.

After the translation was completed and delivered there was some proofread and correction work done. Still everything was like expected and the corrected version was applied correctly.

Because we were still not happy with the translation there was still some change in the wording required. Same procedure like before, open the translation, change the wording, click finish and redeliver.

But now the result was like this:
1. a lot of translated strings are missing completely
2. Some translations are old

After checking it, we can confirm that in both kind of editors the problem is the same. Not only in the post table itself.

So we recovered the previous version of the post (revision) to at least not lose all the work.

The result at the moment is – of course – that if we open the translation editor, the translations there not match the content in the Chinese version of the page itself.

We understand that this is normal because we recovered the post.
But how got all the content lost in the very first moment as the issue appeared?

Steps to reproduce the issue:
1. Choose englisch in admin
2. Go to pages
3. Open 'Home'
4. Click pencil to edit Chinese version of the page (already then you can see, that the translated content not match the one of the Chinese homepage itself
5. Click complete
6. Click Redeliver
7. Result: Most of the languages gone or old.

Please recover the post after!

As I wrote above, we are aware of the restore of the page without language editor can make some new trouble. But the initial issue appeared before and the local translator strictly used the ATE before.

See attached screenshots.

It seems to us like some relations just got lost.

Notes:
• The Chinese page was not edited outside of the translation editor; apart of the restore
• We can reproduce the issue with different admin-users
• We did update from 4.1.0 to 4.1.1 lately
• We did not have this error ever before
• We only have this issue with the specific page
• We cleared all the caches and also pressed all other buttons in trouble shooting

Thanks for your help on this in advance!

December 3, 2018 at 1:21 pm #2962425

yannickS-3

Update: meanwhile we can break down the issue to the following.

1. Local Translator A (admin) is doing the translation of the page: result ok
2. Local Translator B (admin) is editing the translation of the page: result ok
3. Local Translator A (admin) is editing the translation of the page again: result is messed.

The issue is not related to specific languages or posts. It's a general problem.

December 4, 2018 at 11:57 am #2966242

yannickS-3

As requested by Pierre (here https://wpml.org/errata/when-the-translation-is-saved-some-content-is-replaced-with-the-original/#comment-1941308) I want to let you know, that the workaround from the existing issue is not working for us.

The translation in the editor is still showing an incomplete or old one.

December 4, 2018 at 5:10 pm
December 4, 2018 at 5:10 pm #2967508

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please see the above private message that I just left for you.

Thanks,
Itamar.

December 5, 2018 at 3:02 am #2968702

yannickS-3

Done.

The copy was by the way not set to noindex automatically in the site settings nor in the robots.txt. I changed this by hand in the copy now. Just letting you know.

December 5, 2018 at 9:36 pm #2971757

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for setting your site on our test server.

Since it is very hard for me to understand which parts of the homepage are having the problem because I do not understand Chinese, could you elaborate on how I can see the issue?

1. Can specify which sections are showing old translations?
It will be helpful if upload some screenshots of the sections in the Translation Editor and on the front-end.

2. By the way, are those the Divi Global Modules that you are having the issue with?
The Divi Global Modules are showing in green color. On the homepage see the blurb modules. Please see the attached screenshot.

3. Do I need to follow these steps to see the issue?

- Local Translator A (admin) is doing the translation of the page: result ok
- Local Translator B (admin) is editing the translation of the page: result ok
- Local Translator A (admin) is editing the translation of the page again: result is messed.

Regards,
Itamar.

December 6, 2018 at 12:34 pm #2973856

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, there.

In addition to the above and to what Pierre suggested please also check this errata page.
https://wpml.org/errata/cannot-edit-page-builder-translations-with-the-native-wordpress-editor/
Can you please also try the workaround in that page which is to deactivate the Media Translation add-on while editing the translation of the page and see if it works?

Currently, we have some known issues with WPML 4.1.0 and 4.1.1 regarding translations of pages where page builders are used (Divi in your case). Our developers are working to fix it, and a new fixed version (4.1.2 ) should be released soon.

Thanks,
Itamar.

December 6, 2018 at 1:28 pm #2974085

yannickS-3

Hello Itamar,

1. See my screenshot in post! Especially marked some areas as an example (before/after). This should enable you to find it in the frontend. Attached screenshots for some admin part.

2. No it's not the global Divi modules.

3. Because you are already translator B, you just need to save the Chinese version again. Actually you already did redeliver as I can see in the history. In the frontend the page is messed. So you already reproduced the issue.

4. The issue on the 'errata page' is not really related. Because the issue appears if I use the WPML advanced or standard editor. The translations is already missing in the editor, even if it is still available in the frontpage. Also I don't use the media plugin.

What about having a Teamviewer session since it seems to get this sorted out here?

December 8, 2018 at 4:37 am #2980069

yannickS-3

Guys I really try to be patient and understand you have a lot to do, but six days without even getting a confirmation of the issue is a little bit inconvenient for me as a paying customer

December 9, 2018 at 12:27 pm #2981535

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry for the inconvenience that was caused to you by the way that this ticket has been handled.

I can confirm that I see the issue on your site's copy on our test server.

Is it still persisting on your site?

I can also confirm that the workarounds from the errata pages do not work. I also updated Divi to its latest version and tried to see if the issue persists in a minimum environment. According to the screenshot that you shared with us, the missing version of the Chinese translation still appears.

I also tried to delete that the Chinese homepage and redeliver that translations, but it seems that the translations in the Translation Editor (classic or advanced) are the incomplete translations. Until now I could not see where the old translations are or why this problem is happening. I'm consulting our second tier supporters about this issue, but I would also want to ask you for some more information.

1. In the plugins section, I can see a plugin that is called the Divi Widget Builder by Stephen James that create your own widgets using the Divi Page Builder. I'm suspecting that this plugin is incompatible with WPML.
Did you use this plugin on the page where we can see the problem?

2. I can see that the Chinese language that you are using is a custom language with the language code (cn). In WPML -> Languages I can see this message.

There is content in the following languages, but it won't be visible on the site because those languages are not activated.

Please see the attached screenshot ch-simp-miss.jpg.
I suspect that there is a kind of language mixup.
Can you confirm, please that this problem happens only with your custom Chinese language (cn) and not happened because you translated this page in the past in the Chinese (Simplified)
zh-hans language?

3. It will also be helpful for me to know if you ever switched the default language.
Was the default language of the site was another language than the current (English)?

I'm bringing all this information to our second tier supporters, but since it is Sunday, I'll probably have an answer from them only tomorrow. As soon as I have their answer, I'll reply here. But Meanwhile, I also look forward to your reply.

Thanks,
Itamar.

December 9, 2018 at 3:01 pm #2981702

yannickS-3

Hello Itamar,

thanks for your answer.

Yes, the issues is still persistent.

1. The plugin should be not used on that specific sub-page. It’s only used on the blog and enables us to use Divi modules on a widget position.

2. This language was setup in the very beginning and and before we finally started to translate the content. The reason to set this alternate chinese language up was a) we want to ue ‚cn’ In the URL slug and b) because Divi use another font for the Chinese language defined as default by WPML. The language was created before we finally started to translate. The non visible item was a dummy content from before.

3. English was the default language from the beginning.

Please also remember my second message in this thread here. The problem not only appears in Chinese and also not only in the specific post. After I reported it here, we run into the same issue in other posts and languages.

December 9, 2018 at 7:44 pm #2981998

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

I've added this information to our internal documentation about this issue and I'm waiting for our second tier supporters reply.

I'll keep you updated here.

Regards,
Itamar.

December 11, 2018 at 5:48 pm #2989844

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've discussed this issue with two of our second tier supporters. Based on the information that we have they both think that some workflow process was carried incorrectly. One of them writes.
It is possible that the translation that was made with ATE, was with a snapshot of the old data – if the user modified the page with the native editor before finishing the translation with ATE.

Is it possible that something like that happened?

In any case, we need to replicate the issue to be able to help you with it and to see how to avoid it in the future and of course, fix it on our site if the issue is on our plugins. On the copy of your site on our test server, I've updated WPML and its add-ons to their latest versions which came out just recently. And again I've tried to replicate the issue but I couldn't. I've followed the steps that you gave me.
1. Local Translator A (admin) is doing the translation of the page: result ok
2. Local Translator B (admin) is editing the translation of the page: result ok
3. Local Translator A (admin) is editing the translation of the page again: result is messed.
But I couldn't replicate the issue. You can see my test page here.
hidden link
The first translation was done by one user and then the second change was made by another user that I've created ('change'). And then the last change was made again by the user that translated the page at the beginning ('change2'). I logged in through a different browser with the other user.

Can you please try again to reproduce the issue on our server?
If you manage to reproduce it, can you please post a detailed steps list and some screenshot?

Thanks,
Itamar.

December 12, 2018 at 5:22 am #2991663

yannickS-3

Hello Itamar,

1. To: "Is it possible that something like that happened?"
It is possible that the translation that was made with ATE, was with a snapshot of the old data – if the user modified the page with the native editor before finishing the translation with ATE.

I am not sure if I get you right. You mean:
a) whether or not the original english post was edited while the translation in ATE was ready? If so, yes this of course could be.
b) whether or not the translation was edited in standard WP Editor while translation in ATE was done? If so, no, this not happened. The translator only worked in ATE.

2. I updated to the latest versions, cleared all caches and also used all maintenance tools in the trouble shooting area. The issue persists. The main problem at the moment is, that if I open ATE from the original post then ATE contains not the real content which is in the translated WP post. How can we get the actual content back there? Without fixing this I am not able to confirm whether or not the data will crash again after I did the updates.

3. I even deleted the translation job for the buggy pages and create a new. The URL ID in ATE changed and it took the fresh data. The content in ATE is still not the real one from the translated post.

4. Attached a screenshot. There is 3 kind of data. Every translating editor content is wrong, the translated WP post is right. How to refresh this after the data got messed up already?