This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Raja Mohammed 6 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 4, 2019 at 8:03 pm

tylerC-2

I am trying to: Get my existing ACF fields group (flexible content) setup with WPML.

I expected to see: The Translation preferences field in each of my fields.

But the Translation preferences field = is not showing up on any of my fields under my existing ACF fields group (flexible content) even though I have set my fields using Make 'Field Groups' translatable.

The field group is called Modules and is here: hidden link. Each layout is a 'module' that has a .php file that builds the module so on each page you can add modules as if it was a page builder.

April 5, 2019 at 6:52 am #3540983

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

It seems like your site is protected. Can you please share the access details.

I don't see the Advanced Custom Fields Multilingual (ACFML) Plugin in the debug information. Please confirm whether you have ACFML plugin installed and activated.

Regards
Raja

April 5, 2019 at 2:01 pm
April 8, 2019 at 9:19 am #3555893

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I still have restricted access please see the attached screenshot.

Kind regards
Raja

April 8, 2019 at 3:50 pm #3559909

tylerC-2

I apologize for that. I have given you access to all sites in the multisite install.

April 9, 2019 at 11:38 am #3566187

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the access, However, I'm still unable to check the list of plugins installed. Maybe only the super admins have access to it. The translation preference section is available in ACF Multilingual from version 1.1 and above. Please check the version of ACFML installed if the version is 1.0 or lower please update to the latest version.

Let me know the results.

Kind regards
Raja

April 10, 2019 at 5:08 pm #3579293

tylerC-2

I have given you super admin. I can confirm ACF Multilingual is at version 1.1.

April 11, 2019 at 6:42 am #3584105

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the access. ACFML plugin requires WPML String translation installed and activated, I can see the String translation plugin is missing in your site. Kindly install and activate the plugin.

I have also noticed another known issue which prevents installation of WPML plugin from Settings? installer. to fix it you might have to add some edits to the WPML plugin code let me know if you can perform the operation.

If not, I would recommend trying to install String Translation plugin manually using FTP, please refer to the guide hidden link

You can download the plugin from https://wpml.org/account/downloads/

Kind regards
Raja

April 12, 2019 at 2:33 pm #3599923

tylerC-2

Hey Raja,

I had string translation installed on my first attempt and it produced the same problem. I can install it to give you the chance to look at it.

What is the known issue you spoke about? I am comfortable adding custom code to the plugin files if you let me know where and what to add, as well as why we are adding it. I don't install plugins via the Settings -> Installer.

Even with the string management plugin, the field does not show up under any of the fields in my Modules group. Is it necessary to use this Translate this Document feature on field groups? The documentation seems to show that you only need to flag which fields you want to translate/copy/copy once.

Cheers,
Tyler Cooper

April 15, 2019 at 5:39 am #3609807

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Tyler,

String Translation is a necessary plugin for ACF translation to work properly. It uses the plugin functionality to translate ACF fields.

Please make sure you have the following plugins installed and activated
- WPML Multilingual cms,
- WPML string Translation,
- WPML Translation Management
- Advanced Custom fields Multilingual

If you can install plugins without any issue then Please ignore the installer issue.

Please Let me know once you have all the recommended plugins activated.

Kind regards
Raja

April 15, 2019 at 4:32 pm #3615025

tylerC-2

I can confirm all those plugins are installed and activated.

April 16, 2019 at 5:48 am #3618323

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I suspect this to be an interaction with any of your installed (ACF addon) plugins. I can see from your site dashboard there are a lot of ACF related plugins.

In a test environment or after securing a backup of your site Please temporarily disable all other ACF plugin and keep only ACF and ACF multilingual check if you can see the Translation preference field. If you can see the fields enable the plugins one by one and check the issue can be reproduced. This will help us single out the conflicting plugin.

Please let me know the results.

Kind regards
Raja

April 23, 2019 at 12:07 am #3658807

tylerC-2

Hey there,

I disabled all ACF related plugins, and disabled and re-enabled the transactions on this field group and that field still does not show.

April 23, 2019 at 6:01 am #3659711

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for testing, Please provide a snapshot (copy) of your site, You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

I have enabled the private fields for you to securely share the details.

Kind regards
Raja

The topic ‘[Closed] Translation preferences field is not showing up as a field.’ is closed to new replies.