Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Dražen Duvnjak 1 month, 3 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
March 2, 2021 at 4:07 pm #8210241

jetonR

Hello

I had an issue last time i contacted you guys and i was able to fix it, but after i made the translation for those strings all of the content under WooCommerce Print Invoices it is in english instead on two languages english and german. Can you please help me out here. Same i add one string for translation, when i add that doesn't appear on the string translation, but it says that is included.

Thank you

Looking forward to your message

March 3, 2021 at 9:05 am #8214257

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

can you please share a bit more info on what is not working correctly. Maybe the best approach would be if you can show a dummy example on the next clean website.

Then share with me step by step guide on how can I see what is wrong and what should be the correct result.

Sandbox link: hidden link

Steps:
- set up WPML and WooCommerce
- Install WooCommerce Print Invoices plugin
- set up a simple dummy example of the issue

Please let me know how it goes and when can I check.

Thanks and kind regards,
Drazen

March 3, 2021 at 9:51 am #8214771

jetonR

Hello Drazen,

I'm not able to install the plugin since it is a premium plugin. This is the plugin:
https://woocommerce.com/products/print-invoices-packing-lists/

The issue here is everything was working fine, until we had to translate two strings for the english version. I searched them i wasn't able to find them, searched under text strings, i found them and included them on the string translation, i translated them and the next day all invoices were showing in english, instead they need to show on both languages for German in german and for english in english.

When you go under string translation and you search for any string for the print invoices, you have them translated when you are on the english language, but as soon as you switch the language on the bottom and choose german you get both of them in english and you are not able to change anything for the german version, attached a screenshot.

Also i searched for a string i found it and i press include it for string translation, it says that is included but doesn't appear when i try to translate it under the string translation.

Let me know

Thank you

screen_wpml.JPG
March 3, 2021 at 9:54 am #8214801

jetonR

Hello

I'm attaching the second screenshot as you can see it says that is translated, but doesn't appear on the german version, please compare the two screenshots it is the same field.

Thank you

screen_wpml2.JPG
March 3, 2021 at 10:11 am #8215049

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back and sharing the info.

Okay, what I think happened here is when saving plugin admin text you were in a different language, probably in German. Now all of the strings are saved as "new" and as default in German and need to be translated to English.

I suggest you remove these all strings from the WPML String Translation and re-save plugin settings text in English (top language switcher), then add translation in German and it should work correctly.

If you still have an issue, you can share with me wp-admin and FTP credentials in the next private reply and will have a look.

- Please make sure to create a backup
- Please share step by step guide on how can I check and see the issue (PDF invoice file)

Thanks and kind regards,
Drazen

March 3, 2021 at 2:21 pm #8218745

jetonR

Hello Drazen

My issue is not resolved yet, i tried couple of things here to resolve it but still the issue remains. Can i provide you somehow a video of what i mean exactly!

Thank you and let me know

March 4, 2021 at 6:28 am #8224223

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

- Video would be great, you can use a free tool like Loom.

- In order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

You can safely add your information into these fields.

Thanks,
Drazen

March 8, 2021 at 1:44 pm #8252489

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back. I am afraid you have not shared with me more info/video on the issue and what is the problem, but I think I figured it out.

So if I check "Shipping Address" for woocommerce-pip, it shows this is German which is not correct. You can easily rescan the plugin for new changed strings, change the default language of the string as explained and translate the string correctly. It should show correctly, but I am not sure the translation will work correctly.

More info:
- https://wpml.org/documentation/getting-started-guide/string-translation/how-to-change-the-source-language-of-strings/.

I am not sure translations will work correctly, the reason why is because the code of the plugin is changed and adjusted. If you check the code there it is set "Lieferadresse" string manually, which is not correct. In the code it should say "Shipping Address", I have compared it with the original code from the plugin, the image attached.

I suggest you either try the method suggested first above or remove the adjusted plugin and delete all strings for woocommerce-pip. Then install new fresh versions of the plugin, scan for string and translate them correctly (from English to German) as we suggest in our documentation:

- https://wpml.org/documentation/getting-started-guide/string-translation/

If you haven't made these changes to the plugin, you should report it to whoever did it, and they should follow our suggestions.

If you then still have issues (with a fresh install), let us know and we will be glad to check, but I am afraid I can not debug custom code added or custom adjusted plugin code.

I hope I was helpful and you understand our side here. Don't hesitate to ask if you find any problem along the way, I'll gladly help you. 🙂

Regards,
Drazen

Screenshot_1.jpg
March 8, 2021 at 1:57 pm #8252987

jetonR

Hello Drazen

I was the one that changed those three strings manually, but those are the only one changed and I can get them back as they were! Even when they were not changed we had the same problem.

The first link that you have provided how to change the language of the string, I have tried that couple of times but as soon as switch the language it switches back to English when you choose the German language, when you revert that to English you can see that translation in German for that string but it's not working when you print an Invoice.

So the only thing left it will be to remove the plugin and install a fresh version of that!

Let me know

Thank you

March 8, 2021 at 3:22 pm #8254361

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

Please next time mention this kind of things, it can cause a lot of lost time debugging the issue, but you made changes in code manually.

Okay, let's started this over, and I will see if there is anything I can do and how to proceed next.

1) Revert any changes you have done to plugin files and make sure it is same as original files.

2) Share with me step by step guide on how can I check the invoice and what is wrong in there.

Thanks,
Drazen

March 9, 2021 at 11:45 am #8262291

jetonR

Hello Drazen

Sorry for not mentioning that i haver made changes there!

1) Reverted back the file to it's original state

2) Check out the video that explains it better what is the problem

3) Video Link: hidden link

Let me know

Thank you

March 9, 2021 at 12:38 pm #8263107

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

I have checked your video, and you have shown you have issues changing the default languge of your admin text. I am afraid you are getting the correct behavior.

You are adding admin text inside Plugin Customizer in the default website language (German), it should stay as default in German since that is what is entered in the admin field. Then you should translate it to English as you did. You should always add a string in admin in the default website language.

It is not the same behavior for string coming from plugin files and the one you added manually inside plugin customizer settings.

Please check the image attached.

If you still have issues or doubts please share a video or step-by-step guide.

Thanks and kind regards,
Drazen

Screenshot_1.jpg
March 10, 2021 at 2:24 pm #8275619

jetonR

Hey Drazen

As you can see on the video i chose the German version and include a translation for the English version, as soon as i switch that language the EN version takes the text again in German and The German field is empty.

Let me know

March 10, 2021 at 2:45 pm #8275893

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

yes, do not do that.

You should NOT be changing this string translation default language name, as I have already explained in my previous reply, it is the admin text German string.

You should leave it in German, and then click the pencil to translate and edit the translation.

I think we are not understanding each other here, let me know if you still have issues and what is your final problem or what are you trying to achieve.

Thanks and kind regards,
Drazen

March 11, 2021 at 11:41 am #8284339

jetonR

Hello Drazen

Ok I just did that I clicked the pencil and didn't switch to English, but i still have the issue, the invoices are showing only in English. Check out the video of those two test orders that we have made, one of the products it is ordered in the English version and the other one on the German version of the site, but we still get the invoice only in one language, that's English!

hidden link

Thank you and sorry for this talking to long, but we still have the issue going on

Looking forward to hear from you