This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 8, 2018 at 9:54 am #2027113

dcJ

I'm using the Divi theme (version 3.2).
And the latest WPML
When I try to save the translation (either save and close, or just save) the saving keeps going on.
Eventually the translation will be saved, but the saving still seems to continue and it won't close to the pages overview so i have to hit the back button.

After inspecting the errorlog tons of these messages appear:
===================
[08-May-2018 08:57:44 UTC] .../core/module-options.php:65 db_add_module_field_filter():
You're Doing It Wrong! ET_Builder_Section::$whitelisted_fields is deprecated.

[08-May-2018 08:57:44 UTC] .../builder/class-et-builder-element.php:445 ET_Builder_Element::__get():
ET_Builder_Row::$whitelisted_fields is deprecated.

[08-May-2018 08:57:44 UTC] .../core/module-options.php:65 db_add_module_field_filter():
You're Doing It Wrong! ET_Builder_Row::$whitelisted_fields is deprecated.

[08-May-2018 08:57:44 UTC] .../builder/class-et-builder-element.php:445 ET_Builder_Element::__get():
ET_Builder_Row_Inner::$whitelisted_fields is deprecated.

[08-May-2018 08:57:44 UTC] .../core/module-options.php:65 db_add_module_field_filter():
You're Doing It Wrong! ET_Builder_Row_Inner::$whitelisted_fields is deprecated.
===================

When I try to save the original page with the divi builder, no errors occur.

May 8, 2018 at 11:02 am #2028810

dcJ

It seems I spoke too soon about the translations eventually saving. It does not save.

May 8, 2018 at 12:06 pm #2029748

dcJ

Because I'm still trying to solve this myself, another update.

The error only seems to occur at the very end (at 100% translated).
When I untick 1 box, no matter which one (and then the translation of course is less than 100%) it saves just fine. Changes however cannot be seen because a page only shows at 100%.
When I tick the last box to save to 100% it fails to save.

May 9, 2018 at 7:38 am #2045018

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Hope you are using 3.2.2 version of Divi theme. Please upgrade the following configuration for the expected performance of your site and make sure the issue still exists.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

The topic ‘[Closed] Translation save hangs, log states a ton of "is depreciated"’ is closed to new replies.