This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm editing pages in block mode (WP 5.1.1 German / all plugins up to date / fame themes one press theme). And while editing there is a floating item allowing to hande 'settings of multilanguage content' (as I'm using the German version it is displayed as 'Einrichtung des mehrsprachigen Inhalts'). This item floats with the page being edited, but hides sometimes elements I'm editing and can't be dismissed or moved to the bottom of the screen. Only in html/code editing mode does it sit on the bottom of the page. The problem is that the item obstructs page editing in block/visual mode.

Solution: When our 2nd tier specialist deactivate WPML and show the Custom Fields panel, it also overrides the editor. So the issue is coming from the theme.

You can hide the overlayed panel following the attached screenshot and then contact the theme author to fix the issue.

Relevant Documentation:

This topic contains 15 replies, has 3 voices.

Last updated by Carlos Rojas 5 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 16, 2019 at 12:14 pm #3621861

peterP-46

Hi
I'm editing pages in block mode (WP 5.1.1 German / all plugins up to date / fame themes one press theme). And while editing there is a floating item allowing to hande 'settings of multilanguage content' (as I'm using the German version it is displayed as 'Einrichtung des mehrsprachigen Inhalts').
This item floats with the page being edited, but hides sometimes elements I'm editing and can't be dismissed or moved to the bottom of the screen.
Only in html/code editing mode does it sit on the bottom of the page.
The problem is that the item obstructs page editing in block/visual mode.

See attached picture on how this looks.

I don't even know if it is WPML showing this item as there is no footer/link to the author.

But maybe you can direct me towards a solution on how to get rid of this item

thanks for your help

Peter

PS: let me know if you need access and I can provide that info

April 16, 2019 at 6:59 pm #3624973

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

This seems to be CSS/JS conflict. I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

April 19, 2019 at 9:33 am #3644543

peterP-46

Hi Carlos
thanks for the help. I did all steps you recommended. And the issue happens as soon as the OnePress theme is active (Version: 2.2.4 from Famethemes: hidden link).

I have a paid license for the OnePress plus plugin - but whether the plugin is activated or not doesn't make a difference.

I can leave all plugins active, and change to any of the standard WP themes (I tried twenty nineteen, twenty fifteen/sixteen and seventeen) and the issue disappears.

So the theme itself causes the issue. As soon as I use a different theme the multi language settings float as expected with the bottom of the content.

What is next? Do you need access to the site (I did create a copy so the current site can be changed without causing issues) to see which item (js/css) is causing the issue. Or is this up to famethemes to resolve?

thanks again for the help and best regards

Peter

April 19, 2019 at 3:00 pm #3646833

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, Carlos is off for today but will return Monday. Let's try installing your theme on a fresh install and if we are able to reproduce the issue, we can escalate this to our compatibility team. Then, they can get in touch with the theme author to try and resolve it.

I have set up a staging site. Please upload your theme here and we can continue troubleshooting there:
Login: hidden link
Username: demo
Password: yq97m9Z0ZRYk

Let us know once the theme has been uploaded. Thanks!

April 20, 2019 at 7:03 am #3649585

peterP-46

Hi Lauren
I uploaded the theme (OnePress) - I did not activate it.
Please let me know if you want me to do the basic setup of the theme static start page / post page) and create a simple page to show the issue - or just leave as is and you take it from here

thanks Peter

April 22, 2019 at 2:21 pm #3656293

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Peter,
I'm back from the holidays.

I kindly ask you to finish the setup of the theme and reproduce the issue. Please let me know when this is done.

Regards,
Carlos

April 23, 2019 at 2:11 pm #3664543

peterP-46

Hi Carlos
welcome back from the holidays.
I activated the onepress theme (free version shows the same issue, so pnepress plus is not even needed) set some of the theme options.
I then added two English static pages, one with pictures (gallery) and the other just with a number of text paragraphs copied from your website.

You see the page titles as:
- Error page with text
- Error page with pictures

if you edit either page in visual editor mode you will see the issue of the 'Multilingual Content Setup' panel overlapping the page content.
Especially for the text page it is difficult to edit the content. One workaround is to enter enough empty paragraphs so the real content is below the WPML setup panel and after editing the content to get rid of the empty paragraphs again.

Please let me know if you need more info

thanks and best regards

Peter

April 23, 2019 at 5:15 pm #3666431

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Peter,
Thank you very much for your message.

I was able to reproduce the issue in the test site and I have escalated this ticket to our compatibility team. Our compatibility specialists will take a deeper look at this issue and will try to find a solution.

I will keep you updated about the evolution of this ticket.

Thank you very much for your patience and understanding!
Best regards,
Carlos

April 30, 2019 at 4:20 am #3707793

peterP-46

Any news on the topic?

Thank you.
Peter

April 30, 2019 at 2:38 pm #3712343

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Peter,

I don't have any new information yet. I will get back to you as soon as I get an answer from our compatibility specialists.

In the mid time I recommend you to contact the theme's authors and let them know about this issue so they will answer the efforts from our compatibility team to contact them.

Regards,
Carlos

May 3, 2019 at 1:21 pm #3734623

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Peter,

When our 2nd tier specialist deactivate WPML and show the Custom Fields panel, it also overrides the editor. So the issue is coming from the theme.

You can hide the overlayed panel following the attached screenshot and then contact the theme author to fix the issue.

Best regards,
Carlos

May 3, 2019 at 3:43 pm #3736267

peterP-46

Hi Carlos
thanks for the info - so the issue is caused by the theme, but some of the optional items are generated by WPML. So a 'generic' issue where WPML is just one of the options the error shows up?

Thanks for all your work - I'll send the problem to the theme authors and see if they can fix it

thanks again - Peter

May 3, 2019 at 3:44 pm #3736271

peterP-46

I'll send the problem description to the theme authors and hope they can fix it on their side.

thanks again - Peter

May 3, 2019 at 3:56 pm #3736449

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Peter,

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos

May 4, 2019 at 12:17 pm #3740239

peterP-46

Answer from Fame Themes support:

I've read the topic with the WPML support and sorry about that, it's the theme issue and we've noticed about that. It has been fixed in our development branch, soon, the update will be released.

At this time, you can fix this issue by removing the property in CSS code in the file
/wp-content/themes/onepress/editor-style.css line 7, 28

height: 100%
Let me know how it goes.

-----
Changing the css solved the issue