This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I need to translate the string 'Please share this' text coming from the options of 'Ocean Social Sharing' from OceanWP. Solution: The string "Please share this" is set in the theme's options and so it is an admin text.

- Go to Appearance -> Customize - Go to "Social sharing" - Do a small edit of the "Sharing Heading" string (eg. "Please Share This!") - Publish it - Go to WPML -> String Translation - Select the domain "admin_texts_theme_mods_oceanwp" - You should find the new string registered and ready for translation - Translate the new string.

If a child theme is in use, you need to register and translate the string by following the steps in the attached article. You can find the string in + theme_mods_oceanwp-child-theme -> oss_social_share_heading Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-theme-options/

This topic contains 10 replies, has 2 voices.

Last updated by jonB-18 1 year, 5 months ago.

Assigned support staff: Vincenzo.

Author Posts
May 11, 2018 at 2:40 pm #2090173

jonB-18

I'm struggling to translate the 'Please share this' element of 'OceanWP Social Sharing'. I've found a string and translated it but it's not showing. I've contacted the plugin developer and he's suggested I check with you.

Also, is there a way to translate some of the other key dynamic elements like month name?

Thanks,

May 12, 2018 at 2:05 pm #2100202

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

I need more information to be able to help.

1. Can you please paste your WPML Debug information in the Debug information field?
- http://wpml.org/faq/provide-debug-information-faster-support/

2. What is the source of the string that you are trying to translate?

3. In the meantime, can you please verify if there is a cache plugin that needs to be cleared?

4. Check if the "Don't use String Translation to translate themes and plugins" is enabled in WPML -> Theme and plugins localization.
If that option is enabled, please change it to one of the other two: (Translate themes and plugins using WPML's String Translation.....)

5. About the month name, it depends on the source of the string. If the string is coming from a javascript, you may try this solution as an example:
https://wpml.org/forums/topic/translating-datepicker-calendar/

Thank you

May 14, 2018 at 9:05 am #2113557

jonB-18

Thanks, I've added the debug info.

The source of the 'Please share this' text (I think) is a plugin called 'Ocean Social Sharing' from OceanWP.

There's no caching plugin in place.

The 'don't use string translations...' option is not checked (the first one is).

I've rescanned the plugins and added the translation (see the screenshot) but it's not showing.

I'll read the other thread on the month names – thanks.

May 14, 2018 at 11:21 am #2117543

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

if the string is set in the plugin's options you may try to register and translate it using the steps shown in this article:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If that is not the case, can you please share with me a copy of the theme so I can test the plugin in my local install? I'm asking because this plugin requires the OceanWP theme to be installed.

Send me the archive file (you probably want to use Google Drive, DropBox, or similar services)

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there.

Thank you

May 15, 2018 at 11:02 am #2136597

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

sorry for the delay.

The string "Please share this" is set in the theme's options and so it is an admin text.

Can you please try the following steps to translate it?

- Go to Appearance -> Customize
- Go to "Social sharing"
- Do a small edit of the "Sharing Heading" string (eg. "Please Share This!")
- Publish it
- Go to WPML -> String Translation
- Select the domain "admin_texts_theme_mods_oceanwp"
- You should find the new string registered and ready for translation
- Translate the new string.

Please let me know if this solves the issue or if you need further details.

Thank you

May 15, 2018 at 11:19 am #2136942

jonB-18

Sorry, this still isn't working. I'm using a child theme and so I don't have a 'admin_texts_theme_mods_oceanwp' domain. I have the corresponding one for the child theme but, despite rescanning the theme I don't see that string even after making the change.

May 15, 2018 at 4:20 pm #2144281

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

as you are using a child theme you can register and translate the string by following the steps in this article:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

You can find the string in + theme_mods_oceanwp-child-theme -> oss_social_share_heading

Please let me know if this solves the issue or if you need further details.

Thank you

May 16, 2018 at 8:45 am #2152324

jonB-18

Thanks but I'm pretty sure I've done all this but it's still not working. If you look at the attached screen shot I've added the translation but it's just not showing on the front end. Now, this may not be the right place to add the translation but I can't find anywhere else.

May 17, 2018 at 11:33 am #2174737

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

the string shown in your latest screenshot is not the correct one.

I tested the steps I provided in my previous answer on my local install and everything worked correctly with the child theme.

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

If you don't see the form below, please don't add your credentials as they will be publicly exposed:
- hidden link

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

Thank you

May 17, 2018 at 5:05 pm #2180443

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

thank you for the credentials.

I registered and translated the string by following the steps outlined in my previous post here:
https://wpml.org/forums/topic/translation-string-help/#post-2144281

See also the attached screenshot if you wish to find and modify the string translation.

Can you please verify if the issue is solved?

Thank you

May 18, 2018 at 8:46 am #2188604

jonB-18

Thanks, that's solved. I don't know what I was doing wrong but when I followed those instructions I couldn't get that second string to show up. Thanks for sorting it.