This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client wants to translate WPS hide login logins url
Solution:
This string could be translated using the following XML configuration though:
https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

<wpml-config>
  <admin-texts>
    <key name="whl_page"/>
  </admin-texts>
</wpml-config>

However, the solution did not work as confirmed by the client, so most likely this is not possible.

This topic contains 2 replies, has 2 voices.

Last updated by zsoltE-2 2 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
August 12, 2019 at 4:07 am #4378297

zsoltE-2

Hi,
I am using WPS hide login plugin ( https://wordpress.org/plugins/wps-hide-login/)
This plugin replace the wp-login.php to an url set up in admin page.
Can I translate this url also?

Regards, Zsolt

August 12, 2019 at 12:53 pm #4380967

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Zsolt,

Thank you for contacting WPML support!

From what I see, WPS Hide Login offers only two options:
- Login URL
- redirection URL

I'm not entirely sure what will you achieve by translating the login URL. Does it mean that you would have different URL based on language and that you would provide different login URLs in various languages? I'm not sure that it would work.

This string could be translated using the following XML configuration though:
https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

<wpml-config>
  <admin-texts>
    <key name="whl_page"/>
  </admin-texts>
</wpml-config>

I'm not sure that it is possible. Is this similar to what you are after here?
https://wpml.org/forums/topic/multilingual-login-page/

Regards,
Bruno Kos

August 12, 2019 at 3:27 pm #4381861

zsoltE-2

Thank you for your tip. It is not working, but I do not spend more time with that.