This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 20, 2018 at 2:55 pm #2752559

massimoD-3

I am trying to: Translate a page using the WPML translate manager

Link to a page where the issue can be seen:

I expected to see: The translated text inserted via the translate manager, replace the text in the translated page

Instead, I got: The original text without any replacement.

Basically I have wordpress installation with DIVI theme (I have even contacted the Divi support team and they told me to ask to you). I installed WPML Multilingual CMS, WMPL Translation Manager and WPML String translation. When I do create a page and then click on the "add translation" in the text area I can see that WPML adds every theme's shortcodes. The theme is 100% wpml compliant. Can't understand if it is a problem related to installation.

September 21, 2018 at 8:03 pm #2756466

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @massimod-3, welcome to the WPML support Forum!

Have you checked all "Translation is complete" fields on the translation editor? The translation needs to be as 100% completed before displaying.

Could you please send us a screenshot of the shortcodes on the Translation Editor? We will take a look.

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 128mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 3000. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Please let me know if it worked for you.

All the best,
Diego

September 29, 2018 at 8:39 am #2775462

massimoD-3

Unfortunately still have problems. As you can see in the attached screenshot, the translate manager doesn't manage to understand the difference between the text and the native shortcodes of the theme. Please consider that the theme is DIVI from Elegantthemes, a well known theme that I have used a lot of times before, even in conjunction with WPML. Both WPML and DIVI are updated to the very last version.

October 1, 2018 at 11:40 am #2777865

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please send us access to your WordPress dashboard (website URL, login and password) and the link of the page. I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.
Regards,
Diego

October 1, 2018 at 8:41 pm #2779467

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

The credentials not worked. Could you please check and generate a new password?
"ERROR: The username or password you entered is incorrect."

I will enable the private field again.

Regards,
Diego

October 2, 2018 at 11:43 am #2781276

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. The credentials worked. I checked the Translation Editor for the existing pages and they all seem to be ok (see screenshot). Has this been solved already? Sometimes the cause is a communication error between your server and ours, and the website ends up not loading the wpml-config.xml file.

If not, please send us the link of the page or the steps to reproduce the issue and I will check.

Regards,
Diego

October 2, 2018 at 12:10 pm #2781341

massimoD-3

I'm sorry but it still doesn't work. The translation manager seems working but it isn't. If you do change something it is not shown in the translated page.

You should be able to test it by yourself. Try to change the text in the page "Test page for WPML".

October 2, 2018 at 7:42 pm #2782583

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I did some tests and in fact it was not working. After that, I tried to use the manual editor using the steps below:
- Go to the edit screen of the page (default language)
- Change the language using the Language Switcher at the top admin bar
- If it display a warning, click on "Edit Anyway"

To my surprise, it displayed a error (see screenshot). Aparently, the translation is on the trash. So I think this is the cause of the error. To fix it, please try the following:
- Go to Pages > All Pages on default language
- Change the language to english using the Language Switcher at the top admin bar
- Click on "Trash"
- Delete the translation from the trash

After that, go to the edit screen of the page (on default language),do a small modification and save. Now the fields should be updated on the Translation Editor.

Please let me know if it worked for you.

Regards,
Diego

October 3, 2018 at 8:18 am #2783866

massimoD-3

Still doesn't work.

I've created a new page, using the native WordPress page editor and that worked. Then I've created a second page, this time I've used the DIVI builder and, as you can see in the attached image, that didn't worked.

October 3, 2018 at 2:43 pm #2784931

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

For some reason, your website was not loading the wpml-config.xml of the theme. So, I added the following XML code to WPML > Settings > Custom XML Configuration: hidden link

After that I added a new Divi element to the page, saved, then checked the translation editor. It's working now (see screenshot).

Could you check if this also solves the problem on the other page? Please use these steps:
- Go to the edit screen of the page (default language)
- Add a new text element to the page
- Save. It will refresh the fields on the translation editor.
- Check the translation editor

Please let me know if it worked for you.

Regards,
Diego

October 3, 2018 at 4:00 pm #2785160

massimoD-3

Well, things get even worse now. If I try to translate the main page, I can clearly see that the WPML editor get some very old (odd) version of the page, with a lot less text and, most of all, is totally different from the page that is *actual* translation. I mean if you go to hidden link you will get a page, if you open the Italian version on backend and then click to edit the translated version, you get a totally different version of the page, with all the text in Italian also (for both Italian and English). That's so weird!

October 4, 2018 at 11:45 am #2787345

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

In this case I'll need to replicate your site locally to run some test. For this, please temporarily install a plugin called “Duplicator” and "Migrate Guru" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please let me know if this is ok for you.

Regards,
Diego

October 4, 2018 at 2:22 pm #2787784

massimoD-3

Thanks, Duplicator is already installed. You should already be able to download a package or create a new one if you prefer.

Thanks

October 5, 2018 at 1:52 pm #2790986

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. I did a private test copy of the website here: hidden link

To view the website, you need to sign in. The credentials are the same as the ones you sent me: hidden link

After that, I did the following:
- Go to the edit screen of the home page (Italian language)
- Edited some fields (by adding a "test" word to it)
- Added a new text element with the "New element test" content
- Click on "Update"

After that, I went to the translation editor. Apparently all the fields were there. I modified some fields, marked everyone with "Translation is complete" until I reached the status of "100% translated" and clicked on Save. It seems to me that everything worked normally, and my modifications were applied.

You can check on these pages:
- hidden link
- hidden link

Please do the following:
- In the copy, go to the page editing screens (original and translation) and check if the issue has really been solved. Otherwise, please take screenshot of the elements and send us more details that we will check.
- If the issue was solved on the test website, please apply the same steps on your website to see if it solve the issue.

Please let me know if it worked for you.

Regards,
Diego

October 5, 2018 at 6:18 pm #2791522

massimoD-3

Hi Diego,

first of all let me thank you for all the effort you're putting in fixing this issue.

I've checked the test site and it seems working, although as you can easily check, the original site has a completely translated page, while the translation in this test site is only partial.

So even if I should admit that the problem seems somehow fixed on the test site, I don't know what I'm supposed to do on the original one in order to prevent this problem.