This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.58 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by Max 2 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
August 1, 2019 at 6:20 am

Max

I'm trying to assign single string translations to a local translator account.
In my admin account, the job shows up as "not translated" but it doesn't show up in the translator account
I have provided you with 2 login details (first: admin , second: translator account)

An example you can test this out with is Job-ID: 67269 / Title: Passendes Zubehör für

August 1, 2019 at 7:07 am
August 1, 2019 at 12:58 pm #4321975

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I escalated this to our second tier.
Please be patient till we get back to you.

Regards,

August 5, 2019 at 12:36 pm #4340581

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

We fixed it for you: hidden link
Now you can cancel the local jobs.

Please check and confirm.

This was a bug in WPML and our team is working on this.

Regards,

August 5, 2019 at 12:54 pm #4340651

Max

Hi,
thank you for your reply.
It seems like that new translation jobs can now be canceled.

However it still does not work to assign string translation jobs to local translators. After adding strings to the translation basket and creating the translation job, the string does not show up in the translation queue of the translator account.

August 5, 2019 at 1:11 pm #4340723

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

It still does not work to assign string translation jobs to local translators.
- you can cancel a assigned job only if the translator is resign the job

Regards,

August 5, 2019 at 4:03 pm #4341775

Max

Sorry, I don't understand your last reply.
Even with strings that have not been previously assigned to any translators, after I assign them to one, they don't show up in the translation queue in the translator account

August 6, 2019 at 7:14 am #4344671

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I do not see any 'translator' role here: hidden link
And I see these jobs here: hidden link

Can you explain how to check this from a translator account? or how did you check this?

Regards,

August 6, 2019 at 8:05 am #4344973

Max

It#s the second account from the top in your screenshot. I have added the login details in my first private message. In the list of jobs are only pages but no strings. I need to create jobs for string translations

August 6, 2019 at 11:41 am #4346855

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

1. I sent a a translation job from the user 'Toolset'
2. I can see that in a user translation dashboard: hidden link (I created this user and set him as a translator - u/n: translator p/w: Test@123 - delete this user after finish checking)
3. I sent a translation job and assign it to the translator account 'translator1' : hidden link
4. I can see that is assigned to the proper translator : hidden link

You are not seeing the translation jobs assigned to the user 'toolset' in toolset dashboard because 'Toolset' is not a translator but a translation manager:
- Toolset profile : hidden link
- Translator1 profile : hidden link

All you have to do is just follow this:
You can set a user as a translator and add language pairs for him from WPML -> Translation Management -> Translators Relevant Documentation: https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/#setting-up-translators

Then any user who is set as translator can be assigned to the job and that will be displayed in his dashboard > translations

Let me know how it goes.

August 6, 2019 at 12:07 pm #4347115

Max

Thank you Riffaz for your support.
I was able to solve the problem by changing the user role of my translator account from Admin to Subsciber.

After changing the user role, the dedicated String Translation Menu showed up in the Admin Menu of the translator account.