This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 29, 2019 at 2:50 pm #4481911

lucD-2

I'm having in translated pages in WordPress.
Using Phlox Pro theme so using Elementor Pro too.

Allthough for example for a page I have a 100% completion of the translation in back-end, only a part of the translation in shown in frontend of the website.

Also fields which I translated in the back, dissapear after completion so I don't see them anymore when I go back in my translation.

example page = hidden link
image of back of the page is attached
There you will see that a lot of my textfields / blocks no longer show up.

Please provide some help

Luc De Cnuydt

August 29, 2019 at 5:51 pm #4482935

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 30, 2019 at 7:49 pm #4489087

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website and refreshed the translation jobs in order to make the fields with pending translations to appear again. Please, proceed with the translation for all the fields and let me know if you see the translations in your website frontend, here is how:

1 - In your WordPress Dashboard > Pages click to edit your homepage in the default language.

2 - In the page editing screen, click the 'cogs' icon (see attached screenshot) and finish all your pending translations for your homepage and mark it as 100% complete.

Please, let me know if it helps, have a nice day.

August 31, 2019 at 9:00 am #4490529

lucD-2

Hello, thanks for info. I'll try this.

Can you tell me how this work in fact the translations?
Does it only shows the translations when the page is 100% complete?
If so, then it's strange that he already show some translations on the homepage where I have a string translated and indicated translated where others strings which are translated and indicated translated don't show up in the front?

I don't understand the process completely in fact. Can you advice?

Thanks

September 2, 2019 at 5:49 pm #4499481

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Regarding your questions:

1 - "Does it only shows the translations when the page is 100% complete"

All the made translation will appear in your website frontend regardless of a page completation, I mean if you have translated it partially you should be able to see these partial translations.

2 - "If so, then it's strange that he already show some translations on the homepage where I have a string translated and indicated translated where others strings which are translated and indicated translated don't show up in the front?"

In some very specific cases the WPML language cache prevents the translated content of being showed, for debugging purposes in such situations we ask to make sure the page is 100% translation completed and also make a minor editing in the default language page in order to force WPML to see the unstralated fields and this way make it possible to translate them completely.

Please, let me know if my points above replies your questions or if you need any further assistance and clarifications, have a nice day.

September 5, 2019 at 1:36 pm #4519619

lucD-2

Hello

Then I don't understand why for example in the homepage it doesn't show almost nothing translated in French while a lot is already translated (not yet 100%) ?
Also for the contact page, I only see the title to be translated in the backend. Ok the form will be translated via the form plugin I use but the 2 blocks under the form I don't see in the backend to be translated. How this is possible?

Best Regards

September 6, 2019 at 5:32 pm #4526915

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above, thanks.

The topic ‘[Closed] Translations are partionaly showed in frontend of website allthough 100% complet’ is closed to new replies.