This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bobby 5 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
May 1, 2019 at 10:20 am #3717531

Nick

Hi,

I know this question has been raised before but I can't seem to figure out the answer despite reading through many previous support tickets.

I have a multilingual site with 2 (active) languages, Dutch as the default and German as a (live) translation. I have originally set up all the pages as duplicates. When a user made a change to the German translation, the page saved the translations and it showed up fine.

However, now, it seems that when a user makes a change in (any) translated pages - after saving, the translation is not saved and overwritten by the default language (Dutch).

Thanks in advance.

May 1, 2019 at 6:33 pm #3719383

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

This is most likely happening due to the duplication.

When pages are duplicated they are linked together by default meaning that the change is synchronized between both pages.

you need to click on "Translate independently " as this will ensure the changes will not be synced between both languages.

let me know your results please

May 2, 2019 at 1:20 pm #3724817

Nick

Hi Bobby,

Thanks for your reaction.

I'm aware of the fact that I have to translate the pages independently. We've always used this method and it worked fine -- up until now.

When a user makes a change in an independently translated page, it changes back to the default language after saving the page. This does not happen to the entire page, only to the field that we've tried to change before saving.

Thanks in advance.

May 2, 2019 at 10:03 pm #3729403

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible i would like to take a closer look

please provide me with the page in question along with the field you are translating ?

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

May 3, 2019 at 8:57 pm #3737935

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

this was happening because if you go to the default language page you will see at the bottom that all the custom fields are set to "Copy" , which is why your transaltions were getting overwritten.

Setting them to "translate " resolves the issue , i have done this with the CTA field you pointed out and it worked as expected , please do it with the rest of the fields you want to translate and let me know your results

May 6, 2019 at 7:46 am #3745535

Nick

Hi Bobby,

Thanks for you assistance.

I'm not sure why the fields were set to 'Copy'. Since the beginning, they were set to 'Translate' untill recently. We, however, dit not make changes to these settings.

Is there any way to reset this or edit this in bulk? Otherwise I'll have to edit 232 fields by hand.

Thanks in advance.

May 6, 2019 at 8:08 pm #3752503

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Usually these fields are set within your theme's wpml-config.xml file , if you access it you should be able to change them from within there which could possibly be faster

otherwise unfortunately they will need to be changed on the page manually , as we dont have an option for a bulk change.

The topic ‘[Closed] Translations being overwritten by default language’ is closed to new replies.