This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 24, 2019 at 10:55 am #3671785

camillaP

I am trying to:
I have my site in Danish and in English. I sent it to a professionel translator using WPML in order to get it translated to German and I just received the translations.
However, my site is build with Elementor, and on the new German pages the Elementor design has not been duplicated. I can see the German translations (see attached image) but there is NO design, or menu or anything on the German page (see attached image).
Please help me!

Link to a page where the issue can be seen:
hidden link

I expected to see:
hidden link

Instead, I got:
hidden link

April 24, 2019 at 3:00 pm #3674449

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. After you received this page from your translator, has this page been published? You can check the status of the page by following the steps below:

- Click on the Pages > All Pages (or Posts > All Posts)
- Switch to the secondary language
- Search the desired page
- Check the status

If the page is as draft, you should edit this page to publish the content.

Thank you.

April 25, 2019 at 6:04 am #3678991

camillaP

Hi Bruno,

Yes the page is published - and the design is still not showing.

April 25, 2019 at 10:13 am #3681023

camillaP

My issue is resolved now. I have to go into every product's translation and save it - then it implements the design.