Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.49 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by Kristof 3 months, 3 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
May 31, 2022 at 6:41 pm #11356613

Kristof

Still having issues with the new Elementor containers not being picked up for translation, even though all plugins are up to date. Latest WPML should have fixed this.
hidden link shows 100% complete.

June 1, 2022 at 12:02 pm #11361945

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I'll be glad to help you today.

I've checked the page you mentioned, but it didn't open correctly. Would you please check it?

If the Elementor widgets don't appear in the translation editor, you might need to register them for translation first. Kindly check our guide about registering page builder elements. (https://wpml.org/documentation/support/language-configuration-files/how-to-register-page-builder-widgets-for-translation/)

If the elements appear in the translation editor, but the translation doesn't appear on the front end, would need to request temporary access (WP-Admin and FTP)
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private, which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would need your permission to de-activate and re-activate Plugins and the Theme and change configurations on the site. This is also a reason the backup is critical.

✙ I also need your permission to take a local copy of your site to debug the issue without affecting your live site.

Thanks for your cooperation

Regards,
Osama

June 2, 2022 at 11:06 am #11372235

Kristof

When I moved all the content inside another Elementor Container, all the already translated content showed up again in the Translation Editor. It seems you cannot move content outside of the nested containers or you'll lose the already translated content.