This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 20 replies, has 2 voices.

Last updated by Marcel 1 week, 3 days ago.

Assigned support staff: Marcel.

Author Posts
September 20, 2019 at 10:02 am

simonP-7

I am trying to:
Translate my Website from DE to EN. Actually it worked before. But something happend.

Link to a page where the issue can be seen:
hidden link --> Website in German
hidden link --> Webiste in English, translated elements are not shown

I expected to see:
Page should be translated

Instead, I got:
Page is not translated

September 20, 2019 at 10:49 am
September 20, 2019 at 10:50 am #4611559

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Simon,

Thank you for contacting WPML Support.

It looks like that the Frontpage lost the Page Builder content once I updated the pending translation. Could you please check this?

Best Marcel

September 20, 2019 at 10:57 am #4611571

simonP-7

Yes, thats true. But probably because there is no page builder on the homepage. The homepage content is all managed from the theme options:

hidden link

September 20, 2019 at 11:04 am #4611613

simonP-7

I changed the template from default to hompage. Now there is some structure but the content is missing in EN

September 20, 2019 at 11:58 am #4611817

simonP-7

are you checking it?

September 20, 2019 at 2:23 pm #4613003

simonP-7

As its a hotel site to solve the issue is very urgent for me. I deactivated now all WPML plugins. There is still no homepage. May the problem is related to the theme. But any help is appreciated.

September 20, 2019 at 2:42 pm #4613031

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Your Theme is handling the text in wp_options table. I made the content available using the following XML config:

<wpml-config>
    <admin-texts>
        <key name="option_tree">
            <key name="*"/></key>
    </admin-texts>
</wpml-config>

You can now translate the pages under WPML String Translation:
hidden link

Doc: https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

Best Marcel

September 20, 2019 at 2:56 pm #4613145

simonP-7

ok, thank you but im not sure how this should solve my problem. After your changes the content on the homepage disappeared. I guess we will restore a backup. May you will have to check later again.

September 20, 2019 at 3:10 pm #4613245

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

"but im not sure how this should solve my problem."

-> Your Theme can't be translated directly in the Pages, as all the content comes from OT Theme Options -> hidden link

These options are stored in wp_options table, so I made this strings translatable using WPML String Translation. Now you can translate these Strings directly there. During this process I never had the issue that the affected page was empty?

Best Marcel

September 24, 2019 at 8:35 am #4629145

simonP-7

Hello Marcel, I had to install a backup. Can you add the xml part again? Or how can I do it easily? Im sorry, my knowledge about is very low.

Best regards
Simon

September 24, 2019 at 9:15 am #4629507

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Simon,

sure, you can easily add the XML here: WPML -> Settings -> Custom XML Configuration. I added you a screenshot.

Best Marcel

September 24, 2019 at 9:33 am #4629641

simonP-7

Hey Marcel

thx, but I do not have this tabs on my Germain version.

September 24, 2019 at 9:35 am #4629691

simonP-7

Sorry, I havent activated the translation management plugin.

September 24, 2019 at 10:20 am #4630537

simonP-7

there is still something wrong. I do have the admin_texts_option_tree to translate. I translated some text elements on the homepage. See attachment. But they are not translated on the homepage.

hidden link