Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 3 voices.

Last updated by Joan S. Ferrando 3 weeks, 3 days ago.

Assigned support staff: Bigul.

Author Posts
September 2, 2020 at 10:05 am #6923975

marcQ

I am trying to: Translate an unpdated product from english to any other of the languages. It goes ok until you save. Then the translation is lost. The record in icl_translations disappears. However if you insert the corresponding record to icl_translations it works until you save again.

I did disable all plugins (except WPML) and still happening.

It happens also in some of my other websites.

September 2, 2020 at 4:16 pm #6927847

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Please tries the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page, click on Troubleshooting link (blue link in the middle of the page)

2) In the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

3) Create a new Product and translate it to secondary languages

--
Thanks!

Bigul

September 8, 2020 at 10:14 am #6963541

marcQ

After doing the changes, system keeps doing exactly the same.

September 8, 2020 at 4:07 pm #6968005

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have a couple of requests for tracking the issue. Because unable to reproduce the issue exactly in a fresh installation.

a) Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please refer to the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

b) Please let me know the exact steps to reproduce the issue on your site. It will help us a lot in debugging.

--
Thanks!

Bigul

September 9, 2020 at 7:29 pm #6979013

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information and details. Please check the attached images. For example, *Licorella Tour* and *Visit the Winery* products are showing as translated in the dashboard and it is accessible in the frontend and backend.

hidden link

hidden link

Therefore I would like to know you are still having the issues or not. If you are still having the issues please upgrade to the latest version of WooCommerce, WooCommerce Bookings, and WPML plugins after a full site backup and check is there any difference in the result.

--
Thanks!

Bigul

September 10, 2020 at 9:52 am #6983211

marcQ

In fact the product appears and it can be translated.
However as far as you do an update to the english product and you update translations, each translation you update gets lost.
Plugins are updated to the latest version.
I have tried with only woocommerce and WPML and the problem persists.
Feel free to install or uninstall what you need as this is a test environment.
Thank you

September 11, 2020 at 8:22 am #6991443

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. One request. As a part of our debugging and escalation procedures, please allow me to make a copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/).

--
Thanks!

Bigul

September 11, 2020 at 10:13 am #6992273

marcQ

Yes, please.
Feel free to duplicate.

September 11, 2020 at 9:39 pm #6997005

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission, made a copy of the site. I was able to reproduce the issue now. Will do more test on it and get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 11, 2020 at 10:07 pm #6997015

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

The issue is not reproducible while trying with new Products(duplicate of the existing products). So please try with the following products and check the issue is existing or not. This bug may be happening because of the misconfigurations in the database for the existing products.

hidden link

hidden link

Please check it and let me know your feedback.

--
Thanks!

Bigul

September 18, 2020 at 7:33 am #7043293

marcQ

We reached to do this with new and old products.

September 18, 2020 at 1:32 pm #7046163

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Just to make sure, does it happens when you create a new Product? Because I was not able to replicate it exactly while trying with a new Product. So please tries the following steps after a full site backup and check is there any difference in the result.

1) Create a Product for testing
2) Go to WooCommerce>>WooCommerce Multilingual>>Status tab
3) Click on the Troubleshooting link
4) Try the troubleshooting options
5) Go to WPML>>Support page, click on the Troubleshooting link (blue link in the middle of the page)
6) In the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

7) Translate the Products to secondary language
8) Update the main language product
9) Update the translate

--
Thanks!

Bigul

September 19, 2020 at 9:17 am #7050567

marcQ

Did the tests you proposed and the problem persists.
I did uninstall all plugins and themes (except required ones).
Problem still happens with that product.
It also happens in a really similar website in ParesBalta.com domain. In that domain we rebuild almost any product. However problem persist.
Only when WooCommerce Bookings is uninstalled problem stops.
In my opinion there is any kind of incompatibility of WooCommerce WPML and WooCommerce Bookings.
Could you have a look, please.

September 20, 2020 at 7:53 am #7053247

marcQ

The same problem also in hidden link.
Also with WooCommerce Bookings by WooCommerce.

September 20, 2020 at 5:03 pm #7054259

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have tried again on the staging site now with the following products after activating the WooCommerce Bookings plugin. But it works as expected.

hidden link

hidden link

Therefore please check the issue is reproducible with these two products or not. Hope it will help us in tracking the issue.

--
Thanks!

Bigul