This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 6, 2019 at 2:45 pm

andyZ-4

I am trying to: fix an issue where hidden link works correctly without having to link to /de/home

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
These language URLs link correctly without having to add the subdirectory structure in the link and without having to add this to an htaccess directly.

Instead, I got: hidden link and hidden link

June 7, 2019 at 9:09 am #3975097

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I'm truly sorry but I don't understand the issue 🙁

Can you please elaborate a little more so I can better understand?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

June 7, 2019 at 3:44 pm #3977527

andyZ-4

Carlos,

We opened a ticket a while back and you had requested credentials for getting into our FTP and WP to check things out. Our memory limit is set to 128M and has been for a while.

As far as the original issue, we currently are having to force redirect using the following in our .htaccess:

RewriteRule ^home/$ / [L,R=301]
RewriteRule ^de/$ /de/home/ [L,R=301]
RewriteRule ^de$ /de/home/ [L,R=301]
RewriteRule ^fr/$ /fr/home/ [L,R=301]

The plugin is not working if we have the above redirects removed and attempt to visit /de or /fr — the base URL for the German and French language versions of the site.

June 10, 2019 at 9:22 am #3986197

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I tried to visit the site but I need credentials for the Popup access. Could you provide those in your next message?

I have set set your next message private so you can provide the credentials in a secure way.

Note: Add dummy content for the wp-admin and FTP credentials as you provided them already.

Regards,
Carlos

June 17, 2019 at 5:37 pm #4037557

andyZ-4

hidden link
user: ninjarmm
pass: 44974ee8

June 18, 2019 at 11:00 am #4042991

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided. I was able to visit the site.

Please follow this steps:
- Go to WPML -> Languages -> Language URL format -> Different languages in directories (option) -> Click on 'Details' link -> There you will find a list of possible causes to this issue. ( https://wpml.org/faq/server-setting-for-languages-in-directories/ )

Pleas select 'Language name added as a parameter' option -> Save the changes and re-save the permalink structure. If the issue disappears then you can validate that the cause of the issue is not a malfunction of WPML, but a configuration problem as the ones listed above (under the Details link).

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos