Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.37 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 2 voices.

Last updated by gianlucaB-26 1 month, 4 weeks ago.

Assigned support staff: Noman.

Author Posts
June 5, 2020 at 5:30 pm #6307601

gianlucaB-26

Tell us what you are trying to do? English version of home page

Is there any documentation that you are following? Yes I followed the documentation

Is there a similar example that we can see? if you go to the homepage and click on the uk flag the page loads but in Italian

What is the link to your site? weekeyrentals.com

June 5, 2020 at 5:36 pm #6307689

gianlucaB-26

>

June 7, 2020 at 7:28 am #6313683

gianlucaB-26

I have seen that it depends on the markers but I can't get them right

June 7, 2020 at 7:56 am #6313767

gianlucaB-26

I used the automatic translator, I tried to change to manual but it isn't accepting the changes. There are no links in the original language so I don't know how to get by this. Tks

June 7, 2020 at 9:47 am #6314103

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow the below steps and let me know how it goes?

1. Please make sure you have correctly entered your site URL without /it/ from Settings >> General > ‘WordPress Address’ and ‘Site Address’ as you can see in the attached screenshot.

2. Please re-save permalink by pressing ‘Save Changes’ button from Settings >> Permalinks and see if this resolve your issue: https://codex.wordpress.org/Settings_Permalinks_Screen

After that, please clear all sorts of caches in your site plugin cache (if any) / CDN cache (if any) / browser cache and then check, it will hopefully resolve the issue as we have solved such issues before in the same way.

Thank you

June 7, 2020 at 10:30 am #6314243

gianlucaB-26

I followed your instructions and the English home page still isn't appearing. I think the issue is with the fact that the translation is only 98% complete due to a marker I don't really have in the Italia version. pluses attachment. There are no links in the original text so I don't know why I can't complete it Tks

June 8, 2020 at 3:08 pm #6322803

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to deactivate and reactivate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 8, 2020 at 4:47 pm #6323663

gianlucaB-26

Hi if you send me an email address I will add you as a user to my production site I don't have the possibility to create a test one tsk

June 11, 2020 at 11:39 am #6350575

gianlucaB-26

I have created an account for you. did you receive the email? Tks

June 11, 2020 at 12:24 pm #6350859

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

yes got the login email, thanks

June 12, 2020 at 10:06 am #6358183

gianlucaB-26

Hi Could you kindly give me a rough idea as to when you will be able to resolve this issue - Tks

June 12, 2020 at 11:40 am #6359129

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry for delay I am still trying to fix it, will be done on Sunday asap. I ran into my weekend Friday, Saturday are off for me.

Thanks for your patience and cooperation.

June 14, 2020 at 7:30 am #6366825

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have completed the translation to 100% and deactivated the Redirection plugin and issue gone, could you please check and confirm?

Thank you

June 15, 2020 at 3:36 pm #6375685

gianlucaB-26

Yes thank you the translation is now visible. Does that mean that I shouldn't re active/ use the redirection plug in?

June 15, 2020 at 5:43 pm #6376427

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Yes right, that plugin is conflicting with ours so you need to find another way to redirect pages. May be via cpanel of your hosting OR find another plugin OR contact that plugin author if they could help somehow.

Thanks