This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.62 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 2 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 22, 2019 at 9:52 am

harryW-7

I am trying to:

I have added the Chinese translation on the Home Page through the WPML editor and saved. However the translated text does not display on the front end. Just English.

Link to a page where the issue can be seen:

hidden link

I expected to see:

Chinese translated text.

Instead, I got:

The English text displays.

The site is in maintenance mode so you will need to log in to view.

Also I cannot switch the language URL format. Would like to have the translations organised in different directories like this:

hidden link
hidden link

However when I switch it in WPML 'Language URL format' section, all content disappears from the site. Please check.

July 22, 2019 at 11:31 am #4256661

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

The issue might be associated with limited WordPress memory limit or the number of input variables sent by PHP, increasing both the values would help resolve the issue.

#1) Please increase the WordPress Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory if you already see the code in the wp-config please update the values as mentioned below:



/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

#2) - Increase PHP max input vars to a value of 3000, this can be done by yourself if you have access to Cpanel please follow the instruction hidden link
If not request your hosting provider to help you in this case.

Regarding Langauge url issue, Check whether the .htaccess file is writable, goto Settings > Permalinks and save the settings do you see any code that needs to be copied to .htaccess file? this indicate the file is not writable.

I hope this helps you better.

Kind regards
Raja

July 22, 2019 at 1:18 pm #4257763

harryW-7

Hi Raja

Thanks for your reply. As per suggestions 1 and 2 we have increase the WordPress Memory Limit to 256mb and increased PHP max input vars to a value of 3000. Unfortunately the issue has not been resolved. Please can you access the site and check.

The permalinks issue is fixed though so thanks for that.

July 23, 2019 at 5:40 am #4262691

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the update, Glad one of the related issues is solved,

I can see the translation from blogs are visible in the Chinese home page which means the translation works fine, Try completing the translation of the pages whichever is missing the translation check if the issue still persists.

It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Kind regards
Raja

July 23, 2019 at 7:13 am #4263265

harryW-7

Hi Raja

Those updates have been made to the wp-config.php file. Here is the debug.log info:

https://pastebin.com/e4pTwtAK

Hope this helps to fix the issue.

Thanks,
Oliver

July 23, 2019 at 7:15 am #4263273

harryW-7

P.s. The Chinese translation has already been added to the other site pages.

July 23, 2019 at 1:05 pm #4266191

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

There is nothing much helpful in the logs, I would request a snapshot copy of your site so that the issue can be checked locally without disturbing your site.You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/.

I have enabled private fields for you to securely share the details.

Kind regards
Raja

July 24, 2019 at 2:14 am
July 24, 2019 at 6:55 am #4270777

harryW-7

Hi Raja

Did you receive my previous message with the download link? It isn't displaying in the email chain for some reason.

July 24, 2019 at 12:08 pm #4274307

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have received the download link, I will update you once I have any results to share.

Kind regards
Raja

July 25, 2019 at 5:40 am #4279185

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am able to see the translation on my local site,

- Please make sure the translation is 100% complete in the translation editor
- Purge the cache from the proxy cache plugin

I hope this helps you as well.

Kind regards
Raja