Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.47 hours from now. Thank you for your understanding.

This topic contains 18 replies, has 2 voices.

Last updated by Andreas W. 2 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
March 5, 2021 at 2:32 am #8232961

vaO

I am using a CMS connection to translate my WP web site through WPML and memoQ translation software. I got the CMS connection working and sent a test page called Vitamin A + Deworming Basics to translate from English into Spanish, French, and Indonesian. The test page went from WP through WPML to memoQ and the translations were finished in memoQ. Today I downloaded the translations through the CMS successfully from memoQ back into the WP web page. The attached image shows that the translation download is completed. But on the front end the web page still show the incorrect Google machine translated version rather than the correct memoQ translated version.

I went through all the FAQs and 4 Easy Fixes but I did not understand how to do the fixes. They were not very easy. Please let me know why the translations are not showing on the front end and how it can be fixed.

Thank you,

Christy Nichols

WPML status completed.jpg
March 6, 2021 at 6:29 am #8240923

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I understand right, that the page was first translated with Google machine translation and then afterwards send to the memoQ professional translation service but the new translations did never appear on the Front-End?

To help you faster, I've enabled a private message for submitting the debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Best regards
Andreas

March 8, 2021 at 7:32 pm #8256509

vaO

Hello Andreas -

Thank you for your reply and for the simple instructions on sending the debug information. I have pasted the debug information in the box above. I look forward to hearing back from you at your convenience.

Christy

March 10, 2021 at 4:12 am #8269233

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

PHP MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great. You can view the current values at WPML > Support.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

If changing the limit will not solve the issue with the translations then please reach out again.

Best regards
Andreas

March 11, 2021 at 12:17 am #8279121

vaO

Hi Andreas -

How do I access the wp-config.php file? I looked on multiple websites and forums to figure this out, but still cannot find it. One website says I go to the root folders, but how do I find those? Another website says I go to a folder called cPanel and file manager, but I cannot find those either. Another website says from my WP Dashboard I should go to wp-admin -> Elementor -> System Info, but I do not have any of those. How do I do this? Can I set-up a Zoom call with someone to walk me through this?

Thanks, Christy

March 11, 2021 at 12:19 am #8279123

vaO

Also, who is my Hosting Provider? I don't know what that means and do not know who that is.

Thanks,

Christy

March 11, 2021 at 5:06 pm #8288189

vaO

Hello again Andreas -

I contacted people who know technology and they went in to our hosting providers and increased the WP Memory Limit to 256M, as shown in the attached image.

Now that that is fixed, I went into WPML > Translation Management > Translation Jobs and clicked the "Get Translations" icon again shown in the 2nd attached image. When I do that I get a little box that says "Translations Downloaded", but the front-end of our web page still shows the incorrect Google Translated page rather than the correct translation downloaded from memoQ.

Is there a setting that is making the site choose the Google Translation version over the downloaded memoQ version?

Thanks,

Christy

WPML get translations.jpg
WPML memory limits.jpg
March 11, 2021 at 9:29 pm #8289281

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Christy,

Thank you for your message.

I would like to take a look at the site and I have enabled the private reply form. Please provide me access as admin.

Also, please reach out to the hosting support again and ask them kindly to change the value for max_input_vars inside the PHP settings, as the currently used value of 1000 might not be enough in order to translate the page.

hidden link

Regarding the translation service issue I will have a better look at given error and communication logs. It could be that the translation got stuck and our team should be able to solve this.

Best regards
Andreas

March 11, 2021 at 11:59 pm #8289609

vaO

Hi Andreas -

I have contacted our host provider GoDaddy to change the value for max_input_vars and will let you know when that is done, hopefully tomorrow. I have also requested from our WP admin to give you access as an admin and should have that information tomorrow, which I can then send to you.

In the meantime, in your message above you said, "It could be that the translation got stuck and our team should be able to solve this." That got me thinking so I went through the WP page again and found that when I open the page while in Admin mode, it shows the correct translation. But when I open the actual front-end page it is still incorrect. I attached a screen shot showing both the correct (left) and incorrect (right) versions side-by-side.

Thanks and I'll send the admin log-in information when I receive it from our head admin tomorrow.

Christy

WPML correct and incorrect French.jpg
March 12, 2021 at 1:07 am #8289901

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Christy,

Please verify the WP Memory Limit at WPML -> Support. It is by default set to 40M and should have at least 256M.

In case you are using a cache plugin, try toempty the cache and check if the Frontend appears correct.

What do you see when opening the WPML Translation Editor? Are the new translations present? Are you able to apply the translation yourself when opening the WPML Translation Editor or do you get an error?

The private reply form is enabled for your next reply.

Best regards
Andreas

March 15, 2021 at 2:29 pm #8312073

vaO

Hello Andreas -

I am creating a login for you to access our site as an Admin, but it is asking for your email address. Will you please send that to me? The only email I have right now is the "No Reply" email I get when you respond.

Yes, the WP Memory limit was increased to 256M. I have attached a screen shot showing that.

I am looking up how to empty the cache on the page. I did Ctrl-Shift-R, which I believes empties the cache, but nothing changed on the site.

When I go to WPML > Translations I do not get an error message, but I do get "No translation languages configured for this user." So I cannot make edits myself. We specifically bought WPML to interface with memoQ so we would not have to make edits ourselves.

Thank you again for your continued support,

Christy

WPML storage limits.jpg
March 15, 2021 at 2:42 pm #8312317

vaO

Hi again Andreas -

I just cleared the cache - twice - and it did not fix the issue. The incorrect translation is still showing.

Thanks,

Christy

March 16, 2021 at 3:11 pm #8323251

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Christy,

My email is andreas.w@onthegosystems.com

The private reply form is enabled again in order to provide me access to the site.

Best regards
Andreas

March 17, 2021 at 5:37 am #8327583

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Das erstellte Nutzerkonto hat leider nur beschränkte Zugriffsrechte. Bitte erteilen Sie die Rolle "Admin" und geben Sie mir Bescheid, sobald dies geschehen ist.

Mit freundlichen Grüßen
Andreas

Captura.PNG
March 17, 2021 at 2:45 pm #8333947

vaO

Hi Andreas - I don't actually speak German, but thank goodness for Google Translate :). I popped your message in and figured out what you needed. I have changed your role to an administrator so now you should have full access rights.

Thanks,

Christy