This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by nourD 3 years, 9 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 30, 2016 at 2:24 pm #893005

nourD

I am trying to:
Show translations made on the theme strings and the WordPress strings (for comments and pagination).

URL of (my) website where problem appears:
hidden link

I expected to see:
Everything translated on strings to show on the website. As it used to show.

Instead, I got:
Everything went back to original language on the website although strings are translated.

Steps to duplicate the issue:
After I translated the theme strings that I needed, all those translations were showing on the website perfectly. I was only missing the Comment section because my theme picks up that from WordPress. So I needed to add WordPress strings to translate that part. I followed the instructions for adding the WordPress strings and it seemed that it uploaded the strings already with the translations in it, but from that moment on, all the translated text from the theme are not showing on the website. And non of the alleged translated text from the WordPress strings are showing either. At some point I uploaded the .mo file for Spanish since it said file missing even though the strings that WordPress downloaded by itself had Spanish translations. Still, no translations are showing on the website.
Thanks in advance for your help.

May 30, 2016 at 2:43 pm #893026

nourD

Something that I just noticed, initially when everything was working fine, all the theme strings were showing except for the comment box since apparently that was WordPress strings. Now I noticed that the only part that is picking up translation is the comment box.

May 31, 2016 at 3:38 am #893325

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

#1
Could you please check if the strings that are translated from theme are still there with translation?

#2
Could you please go to WPML->Themes & Plugin localization and check if the "Translate the theme and plugins using WPML's String Translation" checkbox is still checked.

I will wait for your feedback.

Thanks

May 31, 2016 at 2:42 pm #893914

nourD

Hi Shekhar

Thank you for helping me. Yes, to both questions. :-s
Thanks.

June 1, 2016 at 2:36 am #894236

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

I will wait for your feedback.

Thanks

June 2, 2016 at 9:11 am #895468

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please check your ftp details, as it's not pointing towards correct place. Could you please check it and let me know the correct ftp details? you can edit the previous details.

I will wait for your feedback.

Thanks

June 2, 2016 at 2:44 pm #895769

nourD

Hi!

Let me know if the new info works. Thank you!

June 3, 2016 at 10:53 am #896563

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Please follow the below steps and let me know if the problem is solved:

1) Deactivate WPML & WPML string translation
2) Install a fresh new copy of both plugins, downloading it from downloads section.
3) Now go to theme & plugin localization and check if the translate by wpml option is enabled.
4) Now check if the problem is solved, if not just change the default language once and check it again.

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

I will wait for your feedback.

Thanks

June 3, 2016 at 7:16 pm #897190

nourD

Hi!

The front end is still not picking up the translated string. I want to check if I followed the instructions the right way:
1) Deactivate WPML & WPML string translation - I deactivated the plugins and erase them from the plugin list. I did this inside wordpress. Do I have to erase the plugin files via ftp?

2) Install a fresh new copy of both plugins, downloading it from downloads section. - I dowloaded the plugins from the wpml site and uploaded the .zip files again thru wordpress dashboard. Should I do it via ftp?

3) Now go to theme & plugin localization and check if the translate by wpml option is enabled. - Enabled.

4) Now check if the problem is solved, if not just change the default language once and check it again. - Done. But nothing :'-(

Please let me know if I followed the steps correctly by doing it through wordpress or if I had to wipe everything form the ftp and upload again through it. Or any other solution you might think of. Thank you again.

June 3, 2016 at 9:10 pm #897237

nourD

Hi! Quick latest events news... I went ahead and deactivated and erased the plugins directly on the wordpress dashboard, but I also deactivated the Toolset and all its plugins just in case, then I opened the ftp and erased the language folder from wordpress, went back to wordpress dashboard and reinstalled wordpress, and as a last step I uploaded the plugins again and... happy news: all the translations (including the comments section) are showing the translated strings. I was so happy that I want to let you know. Not putting the issue as resolved yet because I want to make sure it was not an issue with Toolset. Will come back immediately to close the thread as soon as I activate everything and stays stable. Thank you!

June 6, 2016 at 2:18 am #897670

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Sure, please let me know if everything is OKwith all plugins activated. Will wait for your feedback.

Thanks

June 7, 2016 at 11:03 pm #900434

nourD

Hi! So far that version of my website seems to still work 🙂 Now I've activated another copy of the plugin to a new site with exactly the same theme and plugins (I was basically using that first site as a test before really setting up my real site, and I still have problems with the WordPress translations/strings. I basically followed the same steps except for uploading/erasing a .mo for wordpress in Spanish since last time that was the problem that got solved after removing that file. What is interesting is that the plugin downloaded translated strings for WordPress by itself, but is not picking up those translations. I've uploaded a couple of pics to help me explain. Thank you once more for you help.

June 8, 2016 at 7:43 am #900614

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you please provide me the login details of your new site, so I can debug the issue again?

I will wait for your feedback.

Thanks

June 9, 2016 at 4:19 am #902594

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

#1
Regarding the first screenshot: hidden link

It seems the WordPress core .mo files are loaded only for one language as a reason fully translated strings is showing 0, I have translated the "%1$s of %2$s" string to Portuguese and it seems to be showing 1, so please translate all the strings to available language you will find the fully translated strings showing.

#2
Could you please provide a link where the translation is not working, as I couldn't find any strings which seems to be coming from WordPress itself.

I look forward to your reply.

Thanks

June 10, 2016 at 3:18 am #905209

nourD

Hi and thank you!
I've clicked on "review changes and updates" for the WordPress strings in both languages (Spanish and Portguese). Now the count of translated strings is almost complete. Still, some words like pagination items are not translated in Spanish or Portuguese (I have hidden the Portuguese option in the meantime). I'm attaching a screen shot. One example can be seen on the main website hidden link) on the block of Recent Post close to the footer.
Thank you once again.