This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Mihai Apetrei 1 month, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 8, 2020 at 3:00 pm #5867217

olivierM-39

Tell us what you are trying to do?

I set up WPML :

added one language (german, French being the main language)
translated pages and theme strings
added a language switcher in the menu

But I cant see the language pop up when clicking on the menu - nothing shows up, as if no other language was available.

What is the link to your site?
metanoia-festival.ch

Many thanks

April 9, 2020 at 9:44 am #5874453

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

First of all, thank you very much for your patience and sorry to have you waiting - there is a very full ticket queue at the moment and it takes us a bit more than usual to answer tickets.

Now, regarding your request, can you please try this:

1. Create a full backup of the site
2. Disable all the non-WPML plugins and see if the issue is still happening (if it doesn't, please try to enable each plugin back and check when the issue is happening so that you can find the plugin that creates that issue)
3. If it still doesn't work, please switch from the current theme to a WordPress default theme (like twentysixteen)
4. See if the issue is still happening
5. If it's still happening, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 9, 2020 at 1:11 pm #5876313

olivierM-39

Hi Mihal,

I was able to fix most of the issue - they were related to theme parameters in the pages preventing the pages from showing up properly.

All the translations show up properly now by forcing the language in the url parameter (?lang=de).

The only bug that is left now is related to the menu translation
I will dig into it to see if I can fix it myself, and get back to you if I cant.

Many thanks

April 9, 2020 at 3:25 pm #5877407

olivierM-39

Hi Mihal,

I also resolved the menu issues.
The language selector of WPML was breaking the menu and creating bugs.
I disabled it and hard coded the selector to avoid the issue.

One more question - I would like to translate ninja forms, as explained in the documentation.
https://wpml.org/documentation/related-projects/creating-multilingual-forms-using-ninja-forms-and-wpml/

But in the translation management module, there is no way to select ninja forms in the dropdown menu.
Screenshot attached.

Many thanks

April 9, 2020 at 3:58 pm #5877669

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

I am super happy to hear that the issues are resolved now. Good job!

Regarding the new issue you reported, from what I can see, you don't have the Ninja multilingual plugin installed so that is why you are not seeing the ninja forms in that dropdown.

Please check this: https://wpml.org/documentation/related-projects/creating-multilingual-forms-using-ninja-forms-and-wpml/#getting-started

You should be able to download that plugin from here, under your WPML.org account:
https://wpml.org/account/downloads/

If you still have issues with this matter, please open a new ticket as we are allowed to handle only one issue per ticket.

But what I recommended should help you be able to make the ninja forms show up in that dropdown 🙂

I hope that I made you happy.

Kind regards and please stay safe,
Mihai