This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bigul 3 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
May 25, 2019 at 4:19 am #3888791

alinam-2

I am trying to: save the translations of blog articles

Link to a page where the issue can be seen: whatever article, in admin.

I expected to see: once the saving of translation is finished, back to list of articles.

Instead, I got: the saving is not finishing, never ending, I tried 2 browsers, with storefront, and all plugins desactivated but woo and wmpl

Regards

May 25, 2019 at 5:11 pm #3889707

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details and make sure the issue is existing or not.

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

If you are still having the issue, please check you are getting any JavaScript error in the browser console.

--
Thanks!

Bigul

May 26, 2019 at 5:28 am #3891159

alinam-2

Hello Bigul,
I moved the memory to 256. No impact.

Iknow nothing about JS ... Errors in console:

Firefox:
Erreur dans les liens source : request failed with status 404
URL de la ressource : hidden link
URL du lien source : skin.min.css.map

This is in microsoft Edge:
CSS3119: Aucune police disponible pour la règle @font-face
noticons.css (1,25686)
SCRIPT12008: SCRIPT12008: WebSocket Error: Incorrect HTTP response. Status code 403, Forbidden
HTTP500: ERREUR DE SERVEUR. Le serveur ne peut pas exécuter la requête, car il a rencontré une condition inattendue.
(XHR)POST - hidden link
2SCRIPT12008: SCRIPT12008: WebSocket Error: Incorrect HTTP response. Status code 403, Forbidden

This said, note that save an article in original language normally works. THat's the WPML translation that is not finishing the saving.

Kind regards

May 27, 2019 at 12:35 pm #3897195

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. Please share with me the WordPress debug.log (not WPML debug information) for collecting more information. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

May 27, 2019 at 2:20 pm #3898269

alinam-2

Hello Bigul,
I had discovered recently this debug function recently. But I added what you asked for in the wp-config.php.
I had tried with Storefront as default theme, and all plugins desactivated but woocommerce, editor and WPML. I just tried again. No impact, the issue is still there
The file is too big for paste.bin -non pro user- but you can download it here:
hidden link
Kind regards

May 28, 2019 at 8:08 am #3903801

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am getting the following message while accessing the Debug.log file.

**YOU ARE NOT AUTHORIZED TO ACCESS THIS WEB PAGE AS PER THE DOT COMPLIANCE**

So I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

May 29, 2019 at 4:53 pm #3917575

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. The Debug log is showing following error few times and also there is an error in the browser console.

PHP Recoverable fatal error: Object of class WP_Error could not be converted to string in /*******/wp-content/plugins/wpml-translation-management/inc/translation-proxy/wpml-pro-translation.class.php on line 586

So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

May 29, 2019 at 5:44 pm #3917859

alinam-2

Hello Bigul,
Yes, you can duplicate, I confirm.
I am a real dummy, my impression was that this error was linked with jetpack.
Thank you for your support
Kind regards

May 30, 2019 at 12:27 pm #3922875

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. But I am not able to activate Duplicator plugin on your site. Please check the attached images.

Therefore please check you can install the plugin or not.

--
Thanks!

Bigul

May 30, 2019 at 12:59 pm #3922987

alinam-2

Hello Bigul,
Sorry, I thought that it was installed. So, I just made it.
Otherwise, I am using UpdraftPlus, and as far as I understand, it also enable to clone.
Let me know if you have any other issue
Kind regards

May 31, 2019 at 6:35 am #3927979

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I made a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

June 3, 2019 at 6:15 am #3939521

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the bug is existing after the initial debugging steps. Therefore I shared the details to our second tier team for the expert opinion.

We will get back to you soon. Please wait.

--
Thanks!

Bigul

June 3, 2019 at 7:57 am #3940003

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please note, this issue is happening because of a conflict in updating links of the translations. Our developers are currently working on this issue. As a workaround for the time being please try the following steps after a site backup and let me know your feedback.

1) Activate WPML Sticky Links plugin
2) Go to WPML>>Sticky Links
3) Click on *Start* button near to *Revert sticky urls to permalinks*
4) Wait until the process complete
5) Then try to translate a Post or Page

--
Thanks!

Bigul

The topic ‘[Closed] Translations of blog articles don't finish their savings’ is closed to new replies.