Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

All of the known issues are documented in https://wpml.org/known-issues/ you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described here https://wpml.org/faq/checklist-before-opening-a-ticket-in-wpml-support/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by anneg-4 1 year, 5 months ago.

Assigned support staff: Otto.

Author Posts
October 26, 2017 at 3:36 pm

anneg-4

I have 'options' in my theme that are made up of advance custom field 'Field Groups'. I can add them to or remove them from pages in my site via a toggle.
If I go into the options and specify "All languages" I can see two versions of each option that is available, one for french and one for english. However if I enter copy into one of the french fields, it gets copied into the English fields as well after I save the edit.
You can see this on my home page if you scroll to the bottom and look at "Accepted at more than 1,800 ....." There is a 'fr' in front of the text on both the English and French versions of the page, because the french content overwrites the english content. Not sure what I a missing in my setup, can you advise?

October 27, 2017 at 4:26 pm #1414330

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

ACF options are not supported yet by WPML and ACF Multilingual. We are working to make it happen but I can't provide an ETA.

Meanwhile, I suggest you trying this workaround:
https://wpml.org/forums/topic/cannot-translate-field-groups-independently/#post-1331910

Let me know if it helped, please.

Kind Regards,

Otto

October 30, 2017 at 9:31 pm #1416206

anneg-4

The workaround felt like a lot of trouble to me, although thank you very much for suggesting it. I ended up doing a brute force sort of solution with a few additional custom fields for translation purposes. So I am all set. Thanks for your help.