This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Manuela Casinghini 1 year, 4 months ago.

Assigned support staff: Lauren.

Author Posts
May 23, 2018 at 1:43 pm #2215785

Manuela Casinghini

Hi,
I have 2 languages on my website, Italian and English.

I have created the traditions with option, but when I make a change for example on the Italian card (primary language), such as date block, the changes are overwritten the titles of the icons in the primary language.

I have also disabled synchronizations in the management of translations, but the problem persists.

Can you help me?

Thanks,
Manuela

May 24, 2018 at 1:44 pm #2223230

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you please tell me if you are translating the page using the Translation Editor or the traditional WordPress editor? Also, is this page content created using a Page Builder?

I'm not sure how the content was created but you can try going to WPML -> Translation Management -> Multilingual Content setup and if this content is related to a custom field, type or taxonomy, make sure it is set to Translate and not Copy.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

May 24, 2018 at 4:09 pm #2224425

Manuela Casinghini

Thanks for your help

May 24, 2018 at 5:41 pm #2224766

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You are welcome. Were you able to translate the content now? If so, you may mark this ticket as resolved. If you need further assistance, just let me know and I'm happy to help.

May 24, 2018 at 5:50 pm #2224779

Manuela Casinghini

No I could not solve the problem,
I pasted the debug in the previous answer.

Excuse me for misunderstanding,
Manuela

May 24, 2018 at 6:51 pm #2224996

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Can you please answer my previous questions so I have a better understanding of how this content is created?

Can you please tell me if you are translating the page using the Translation Editor or the traditional WordPress editor? Also, is this page content created using a Page Builder?

I'm not sure how the content was created but you can try going to WPML -> Translation Management -> Multilingual Content setup and if this content is related to a custom field, type or taxonomy, make sure it is set to Translate and not Copy.

May 24, 2018 at 7:25 pm #2225197

Manuela Casinghini

1 - Translation Editor or the traditional WordPress editor?
Create translations manually
2 - The page is create with default editor with layout Goodlayer option (img)
3 - Custom Fields Translation - Set to Translate
Custom Term Meta Translation - Set to Translate
Post Types Translation - Set to Translatable - only show translated items
Taxonomies Translation - Set to Translatable - only show translated items
Thanks,
Manuela

May 24, 2018 at 7:40 pm #2225212

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

May 29, 2018 at 10:12 am #2244514

Manuela Casinghini

Hi Lauren,
sorry for my answer, but I was out for work.

I solved the problem, set some terms of the custom fields, type or taxonomy not translatable and other translatable, this allowed me during the synchronization of not overwriting one language with the other.

Thank you,
Manuela