This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 1 month, 1 week ago.

Assigned support staff: Noman.

Author Posts
September 11, 2019 at 10:59 am #4552809

magnusM-4

I am trying to:Add two different languages and did all translations.

Link to a page where the issue can be seen:hidden link

I expected to see:Two different content on two differernt languages

Instead, I got:Same content on both languages

September 11, 2019 at 3:55 pm #4555147

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please make sure that the home page is 100% translated?

1. Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

2. Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/
3. Please delete all sorts of caches on your site / server cache (if any) / plugin cache / CDN cache (if any), clear browser cache and see if this resolves your issue.

4. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

September 12, 2019 at 7:03 am #4558717

magnusM-4

Yes, I have checked all my WPML minimum requirements.
Hi, could you please check my debug information.

September 12, 2019 at 4:29 pm #4563289

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

The topic ‘[Closed] Translations showing same content on both languages’ is closed to new replies.