This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Performance issue happens with these symptoms: Translations sometimes are not saved to the database. CPU-Usage is up to 100%.

Solution:

The latest version of WooCommerce Multilingual (4.6.2) solved this issue. Please update WPML and its add-ons to their latest versions.

0% of people find this useful.

Author Posts
April 8, 2019 at 9:44 pm #3561485

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rich.

You can send me access to the live site but what I need is to deactivate the theme and the plugins and this you do not want me to do. So I'm kind of stuck and not able to continue debugging this performance issue.
Do you have a staging site where it is the exact copy of the live site on the same server where I can deactivate the theme and the plugins?
If so then please share it with me. I'm enabling a private message for the next reply.
Alternatively, you can migrate your site again to our test server.

Thanks,
Itamar.

April 8, 2019 at 10:00 pm #3561503

richS-2

Hi Itamar,
sorry, you're absolute right, it would be the the best if I would transfer the site to your server as you can switch themes and stuff without worries.

Anyhow here's a admin login to the live site, remember it's live so please do NOT edit anything. Maybe you want to check my WPML-settings, I would be really gratefull. 😉

Would you give me another cloudways setup so I could transfer the site to your server?

Best
Rich

EDIT: I don't get it how I can post things privately here, like logins and stuff, probably I'm to stupid.. 😉

April 8, 2019 at 10:13 pm #3561517

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You cannot send private replies. I'm sorry if I forgot to enable it in my last reply. I'm enabling it now.

I do not need to set up for you a new Cloudways setup. You can use the same information that I already gave you. The new site that you will migrate will override the current site.

Thanks,
Itamar.

April 9, 2019 at 9:04 am #3564659

richS-2

Hi Itamar,
the migration to your server is completed!
Let me know if you need anything more...

Best
Rich

April 9, 2019 at 5:21 pm #3569673

richS-2

I saw you where trying to access admin of the live site. The site is currently in maintenance mode, manually via htaccess. It looks like the sql/php server is frozen since 7 hours and the support (it's a reseller) does not respond. I have access to cpanel but i cant find any possibility to restart this.
html pages work, php doesn't.

April 10, 2019 at 11:47 am #3575587

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rich and sorry for the late reply here.

I've checked many on your site's copy on our server. I didn't continue to check the issue on your site, and anyhow currently it is not available.

First, I want to mention the DB changes that I've made which I've said before.
A. I've corrected the ICL_TRANSLATIONS table the element_type column type. It was varchar(36) [post_post] and I changed it to varchar(60) [post_post]. Also, many of the icl tables were with the engine of MyIsam, and I changed them to InnoDB which is more common and performance-wise better. And indeed I think that this by itself improved the performance, but still, it was not good at all.

Then I've continued to debug this issue and found out that the primary cause of the performance issue was in the child theme and not related at all to WPML. You are using a child theme for the Storefront theme By Automattic. Only by switching to the parent theme reduced the loading time on the shop page by far. When the child theme with WPML and all the other plugins were activated, the loading time was around 42 seconds. But when I switched to the parent theme the loading time reduced to about 12 seconds. Apparently, the loading time even increased when I deactivated WPML and the child theme will all the third-party plugins were active. It was more than 50 seconds. Please see the attached screenshot. So I would recommend you to check what is wrong with the child theme that you are using. Please understand that this is not related to WPML.

But still, I've continued to debug the performance issue to check what overload WPML puts on the site when it is active. For that, I've activated the parent theme and deactivated all the third-party plugins (except WPML and its add-ons, WooCommerce without any add-ons and the Query monitor). When WPML is active, there is a loading time which is 5 seconds higher on the shop page and when I update a product page. Without WPML the shop page load at around 3 seconds and updating a product page takes about 5 seconds. And as mentioned there is an increase of5 seconds when WPML is active.

Therefore I've now escalated this performance issue to our second tier supporters, and they will check it. We'll keep you updated here for any news regarding this issue.

Thank you for your patience.
Itamar.

April 10, 2019 at 7:54 pm #3581079

richS-2

Hi Itamar,
thank you very much for your intense investigations. Right now I'm busy moving to a new host. As soon as this is done I will further check the child theme and let you know if this is solved.
Until then I'd like you to delete some of the info in this thread. If you could open up private message for me I would send you what should be deleted. Ok?
Thanks again!
Best
Rich

April 10, 2019 at 8:05 pm #3581123

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rich.

Private message is enabled for the next reply.

Regards,
Itamar.

April 10, 2019 at 8:11 pm #3581175

richS-2

Hi and thanks very much for the quick response. Here's what should be deleted:

--removed by supporter---

again thank you for all your work and sorry for keeping you busy with this stuff. I'll get back to you within the next days!

Best Regards
Rich

April 10, 2019 at 8:26 pm #3581221

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Rich for your information external links (links that are outside wpml.org) are hidden to everyone except you and our support team. Even other WPML users cannot see them. If view this ticket on a browser where you are not logged in you would see that the links are hidden. Please see the attached screenshot.

Best Regards,
Itamar.

April 10, 2019 at 8:31 pm #3581259

richS-2

Ok, thanks. I wouldn't mind if you could leave this ticket open so I can give you feedback within the next days.

Best
Rich

April 11, 2019 at 8:51 am #3585285

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Rich.

This ticket would stay open. As I've mentioned the performance issue on your site is now escalated to our second tier supporters. I'm still waiting for them to check this issue. When I have a reply from them, I'll get back to you here.

Thank you for your patience.
Itamar.

April 28, 2019 at 8:00 am #3697359

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Our second tier supporter suggests that you update your site to WPML and add-ons latest versions (if you haven't done so yet), and see if the performance of your site is improved. With the latest versions of WPML 4.2.6 and WooCommerce Multilingual 4.6.2, our developers improved performance issues. Please check if it is improving your site's performance.

Thanks,
Itamar.

May 1, 2019 at 4:42 pm #3718935

richS-2

My issue is resolved now. Thank you!