This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The client sent some documents to SDL service, and then he cancelled them on SDL, but they are still in-progress in WPML, even after going to WPML -> Translation Management and clicking on "Check Status and Get Translations".

Solution: The client deactivated the service on WPML panel and then authenticated it with new credentials, which made him disconnected from his old project and WPML was not able to synchronize the status of his jobs with the server, so we have cancelled the jobs in WPML following these steps:

- Please go to WPML -> Translation Management -> Translation services and deactivate the SDL service. - Then go to the "Translators" tab, and add your self as a local translator. - Then go to "Translation Dashboard" tab, and add the docs to the basket. - Then go to the "Translation Basket" and then send the jobs to yourself. - After that go to the "Translation Jobs" tab and you will find that these jobs are assigned to you which will give you the ability to cancel them, so please mark the checkbox beside each job and then click the cancel button at the end of the table.

Relevant Documentation: https://wpml.org/translation-service/sdl-language-cloud/

This topic contains 11 replies, has 3 voices.

Last updated by billT 1 year, 4 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
May 11, 2018 at 2:35 pm #2090150

billT

I'm not sure if I cancelled my translation correctly, but not I am stuck.

I deleted two translation jobs from the SDL side which were not approved, so that I could get those pages back in wordpress for editing.

After I deleted and went into translations jobs and synchronized the status I was seeing this error in my logs after nothing seemed to happen.

"Cannot communicate with the remote service | url: `hidden link` method: `GET` param: `{"method":"GET","sslverify":false,"timeout":60,"headers":"Content-type: application\/json"}` response: `{"headers":[],"body":"{\"status\":{\"code\":10,\"message\":\"Can't find this batch, or you don't have access to it.\",\"debug\":\"\"},\"response\":null}","response":{"code":404,"message":"Not Found"},"cookies":[],"filename":null,"http_response":{"data":null,"headers":null,"status":null}}`" thrown in /var/www/d2l/wp-content/plugins/wpml-translation-management/classes/translation-proxy/class-wpml-translation-proxy-networking.php on line 128
at WPML_Translation_Proxy_Networking.call_remote_api(translation-proxy/class-wpml-translation-proxy-networking.php:59)
at WPML_Translation_Proxy_Networking.send_request(translation-proxy/translationproxy-project.class.php:496)
at TranslationProxy_Project.check_status(classes/class-wpml-translation-management.php:347)
at WPML_Translation_Management.check_batch_status_ajax(:0)
at .call_user_func_array(wp-includes/class-wp-hook.php:286)
at WP_Hook.apply_filters(wp-includes/class-wp-hook.php:310)
at WP_Hook.do_action(wp-includes/plugin.php:453)
at .do_action(wp-admin/admin-ajax.php:97)
at .{main}(translation-proxy/class-wpml-translation-proxy-networking.php:128)

Is there another way to unlock these pages, so I can work on them?

Thanks,
Erik

May 12, 2018 at 10:57 am #2099231

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello Erik, thank you for contacting WPML Support!

1. This can be a temporary connection issue. Please try these steps:

- Go to WPML -> Translation Management -> Translation Jobs,
- Click on “Synchronize Status” button for the batch that has been canceled
- Go to WPML -> Translation Management
- Click on the “Check status and get translations” button (if available)

2. Can you please verify if the WPML registration is complete and correctly matches the site's address?
You can check from Plugins -> Add New -> Commercial

Try also pressing the "Check for updates" button on the same page.

Please let me know if this solves the issue or if you need further details.

Thank you

Related documentation:
https://wpml.org/translation-service/sdl-language-cloud/#cancelling-translation-jobs

May 15, 2018 at 7:47 pm #2146681

billT

Did all those steps and confirmed the site registration is still working.

Items are still locked.

May 17, 2018 at 11:36 am #2174751

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you for your answer.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue and to escalate this ticket to our 2nd Tier Support.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

If you don't see the form below, please don't add your credentials as they will be publicly exposed:
- hidden link

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

Thank you

May 17, 2018 at 3:59 pm #2179271

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you for the WordPress credentials.

I'm escalating this issue to the 2nd tier support.

1. In the meantime, can you please update WPML to the latest version (3.9.4)?

Thank you

May 18, 2018 at 6:10 pm #2191358

billT

I will try and get it updated.

May 19, 2018 at 9:27 am #2193616

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you,

our 2nd tier support is already working on this.
I will keep you updated.

Thank you for your patience

May 23, 2018 at 1:35 am #2212424

billT

Any update?

May 23, 2018 at 12:58 pm #2215374

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from the second tier support team.

I have checked your project on our TP server (the middleware service between WPML and SDL) and as I can see that your site has been disconnected from your old project and has been connected to another one, so maybe this happened because you have de-activate the service and activated it again with a new credentials, so now SDL has deactivated your old project because you are not connected to it anymore, and that is why WPML is not able to know that your old jobs have been cancelled.

Then I assume that you want to cancel the jobs in the following two batches, right?
German Blogs and Resources |en
German Site pages|en

- So to cancel them, first thing, please go to WPML -> Translation Management -> Translation services and deactivate the SDL service.
- Then go to the "Translators" tab, and add your self as a local translator.
- Then go to "Translation Dashboard" tab, and assign these pages to yourself
- After that go to the "Translation Jobs" tab and you will find that these jobs are assigned to you which will give you the ability to cancel them, so please mark the checkbox beside each job and then click the cancel button at the end of the table.

Please let me know if that helps you.
Best Regards.

May 23, 2018 at 1:42 pm #2215783

billT

Thanks. When I go into the translations dashboard I can't seem to assign to myself.

I can select the items but then in the translations option box I can't select translate. Attached is a screenshot.

May 23, 2018 at 1:59 pm #2215805

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

In order to be able to choose the "Translate" option, you have to deactivate the SDL service, so I have deactivated it for you, now you have to choose the "Translate" option, then add the documents to the translation basket, and then go to the Translation Basket tab and assign them to your self and send them.

Best Regards.

May 23, 2018 at 2:40 pm #2216378

billT

Thanks. I guess I just de-authorized the SDL plugin.

This has resolved the issue.