This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Noman 3 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
June 27, 2019 at 3:41 pm #4101371

ericW-20

hidden link shows "no result found"
but I do have an english page when I am logged in... I don t understand

June 27, 2019 at 5:04 pm #4101773

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Is it only happening with this page or other pages as well?

1. Could you please make sure that the translated page is 100% translated and published?

2. Please re-save permalink by pressing ‘Save Changes’ button from Settings >> Permalinks and see if this resolve your issue: https://codex.wordpress.org/Settings_Permalinks_Screen

3. Please check ‘Store a language cookie to support language filtering for AJAX’ checkbox from WPML >> Languages > Language filtering for AJAX operations

4. Please delete all sorts of caches on your site / server cache (if any) / plugin cache / CDN cache (if any), clear browser cache and see if this resolves your issue.

5. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

July 1, 2019 at 7:18 am #4115993

ericW-20

We did all the steps but we still have the issue. Thanks in advance for your help

July 1, 2019 at 12:45 pm #4118997

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 2, 2019 at 9:02 am #4125081

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I see your english page status is set as Draft that’s why logged out users were not allowed to see that page. I have changed the status to Publish and issue is gone.

Could you please check and confirm?

Thank you

The topic ‘[Closed] translations unavailable when not logged in’ is closed to new replies.