This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I start getting issues with the WordPress editor when Yoast and Yoast Multilingual are active

Solution: Please update your site to WordPress 4.1.X in order to fix this issue

This topic contains 4 replies, has 3 voices.

Last updated by stefanE-20 10 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
November 22, 2018 at 8:24 am #2929316

mikeL-15

Hello,

There is a trouble between SEO by Yoast Plugin and WPML Plugin after the last update of SEO Yoast to Version 9.2.1.

The problem:

The problem is in the editor. The WordPress editor not works well. So i can't scroll down and use the tools in the editor in the same time, because the tools always stay up.

Also i cannot open and use the html editor. And there are problems when i will mark some text in bold.

The next problem is, that i can't edit the SEO Yoast Meta description down the content. It's impossible.

So i checket this issue in other pages without WPML plugin and there SEO by Yoast works well. I deactivated the WPML Plugin on my page and here also all works well.

So the problem is a trouble between WPML Plugin and SEO by Yoast.

Please have a look on this issue and let me know.

Thanks and regards,

November 22, 2018 at 4:38 pm #2931556

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

This is a known issue and is already fixed but will be live in the next release of our plugin, but in the meantime we can offer you 2 workarounds:

1) Install the gutenberg plugin: https://wordpress.org/plugins/gutenberg/

2) Revert to Yoast 9.1 by following this link: https://downloads.wordpress.org/plugin/wordpress-seo.9.1.zip
or
@ https://wordpress.org/plugins/wordpress-seo/advanced/

I'm sorry for the inconvenience this has caused you but i hope these 2 workarounds will be useful to you while you wait for the next release of our plugins.

Regards.

November 22, 2018 at 6:11 pm #2931730

mikeL-15

Hello Alejandro,

Thanks for your fast reply. Ok, i'll check this and wait for your next update.

Best regards,

November 28, 2018 at 2:50 pm #2948664

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!

I just wanted to let you know that we just released WPML 4.1 which should solve the Yoast Problem, so, if you wish, you can update your WPML plugins (and Yoast) and let me know if you don't experience it anymore.

Regards,

Alejandro.

August 1, 2019 at 1:09 pm #4322063

stefanE-20

...it works.....