This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Yvette 1 year, 5 months ago.

Assigned support staff: Yvette.

Author Posts
May 4, 2018 at 2:14 pm #1976963

Ashish Kumar

I am trying to: Trying to change UI for blog post page for all language, it is changing on my default language but not for others.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got:hidden link

May 7, 2018 at 12:27 pm #2011215

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I have visited the pages and can confirm that I see the layout is different for each language. Can you tell me if you have customized the theme options to achieve the "look and feel" that I see in the EN version?

If so, then it would be that these same theme options need to be translated to the other target languages. This is ususally done via the entry of custom XML entries in the tab:
WPML -> Translation Management -> Custom XML Configuration

Here you would enter the revised theme options as per this documentation:
https://wpml.org/documentation/support/language-configuration-files/#admin-texts

I can help you do this if you prefer. If you need help, you can reply with theme access permission --AND-- links to where you have modified the theme options settings.

Temporary Access to your system
Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

May 9, 2018 at 2:03 pm #2053734

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´m having trouble installing additional plugins on your site or connecting via FTP.

Could you please do the following:

1. Install and activate the ARI Adminer plugin
2. Install and activate the Filemanager plugin
2. Double check the FTP access

Thanks

May 9, 2018 at 2:14 pm #2053901

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello again,

You are running very old versions of the WPML plugin and your WordPress version is quite old. The support I can give you is limited.

Please upgrade you WPML plugins as well as the version of WordPress to the latest releases. This is important for me to be able to support you.

I´ll wait for you to let me know when this is done.

I also have to warn you that the support forum is for bugs in our own software or for assistance on how to use our API. If your theme is highly customised, there may be a point where we refer you to a contractor to resolve your issue. (see image)
https://wpml.org/purchase/support-policy/

May 10, 2018 at 6:23 am #2065457

Ashish Kumar

Hi,

We don't want you to debug the entire code, We have made few changes to the theme code to change the UI and we want to do the same for other languages as well. Changes have been made to following files.

/var/www/html/blog/wp-content/themes/sparkling/single.php
/var/www/html/blog/wp-content/themes/sparkling/content-user-manual.php

We just need you to guide us where can we make the same changes for other languages, as we are unable to find it, just guide us in the right direction and we will do it ourselves.

We checked for the FTP access and its working just fine, please use sftp to connect.

Please let know if you need more information.

Thanks

May 10, 2018 at 7:20 am #2066410

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I´ve taken a look at the code.

Here are my observations.

1. If the layout is not similar, then the problem is within the single.php.
2. The content area seems to be the same in both languages - so the problem does not seem to e there

3. I found only one line that makes reference to any kind of "language"(see image). I would start there.

4. Your code does not use the recommended WPML API so, really, I must refer you to a certified contractor for any further questions.

5. To get support from the forum, you must be using the latest WPML release and the code should be using the correct WPML API codes in any custom coding you have done.

Being that this is not the case, I need to refer any further questions to a certified contractor here:
https://wpml.org/contractors/

If you finally upgrade your system plugins and convert your code to use the WPML API, our support forum will do its best to help you.

The topic ‘[Closed] Trying to change UI for blog post page for all languages’ is closed to new replies.